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The electronic educational and methodological complex (EEMC) part 2 is 

intended for undergraduates studying in the specialty 1-31 80 02 “Geography” and it 

could be useful as well for the specialty 7-06 0532 01 “Geography”. The content of the 

EEMC involves increasing the efficiency of managing the educational process and 

independent work of undergraduates in mastering the academic discipline “GIS in 

Mineral Resource Management” through the introduction of innovative educational 

technologies into the educational process, ensuring high-quality training of highly 

qualified geographers.   
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EXPLANATORY NOTE 

The electronic educational and methodological complex (EEMC) “GIS in Mineral 

Resource Management” is designed to implement the requirements of educational 

programs, educational standards and training in the specialty 7-06 0532 01 

“Geography”. It could be useful also for the specialty 1-31 80 02 “Geography”. Its 

presence provides the stability of the quality of the educational process and is a 

methodological basis for ensuring effective independent work of undergraduates. The 

total course consists of 126 hours, which includes 52 classroom hours; lectures – 8 

hours, laboratory classes – 12 hours, curricular control of managed independent work 

– 32 hours, tests at the end of the course with an exam – 3 hours.  

The EEMC compiled in two parts. Part1 includes a description of the following 

software packages: GMT [ ], Oasis montaj, Surfer, Introduction to ArcGIS, and Strater. 

The part 2 includes mainly the description of laboratory works (tests) proposed to 

students and compiled for the QGIS-3 release. 

The EEMC for the discipline “GIS in Mineral Resource Management” was 

created at the scientific-methodological and software-technical levels corresponding to 

modern information and communication technologies and is designed to ensure the 

implementation of educational goals and objectives at all stages of the educational 

process in this discipline. 

Its purpose is to implement requirements of the educational standard and 

curriculum, ensuring the continuity and completeness of the learning process, 

systematization and control of knowledge in the discipline “GIS in Mineral Resource 

Management”. 

The goal of the EEMC is to increase the efficiency of managing the educational 

process and the independent work of undergraduates in mastering the academic 

discipline “GIS in Mineral Resource Management” by introducing innovative 

educational technologies into the educational process, ensuring high-quality training of 

highly qualified specialists.  

Scope of application is for distance learning, conducting classes on the subject 

“GIS in Mineral Resource Management”, during independent preparation for 

classroom lessons, current and final control of knowledge in sections of the discipline, 

orientation in performing controlled independent work. 

The functionality of the EEMC are the means of orientation in the content of the 

discipline “GIS in Mineral Resource Management” and the order of studying 

educational material, mastering theoretical and practical material, preparing for 

knowledge control. All EEMC material is structured into parts in such a way that a 

master’s student can master knowledge on the specified subject independently. EEMC 

on “GIS in Mineral Resource Management” includes four main sections: theoretical, 
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practical, knowledge control and auxiliary ones. The part 2 includes 9 laboratory works 

using the QGIS-3 release.  

The theoretical section of the EEMC contains lecture notes for the theoretical 

study of the academic discipline (part 1), based on lecture notes for the course “GIS in 

Mineral Resource Management” [electronic resource] / BSU The Electronic Library of 

BSU.  

The knowledge control section of the EEMC contains materials for knowledge 

control and certification, which make it possible to determine the compliance of the 

results of students’ educational activities with the requirements of the educational 

standard and educational program documentation for the specialty. This section 

includes options for test tasks, questions for the exam, a list of tasks and measures for 

controlled independent work.  

The auxiliary section of the EEMC contains training programs on “GIS in Mineral 

Resource Management”, a list of information and analytical materials [electronic 

resource] / BSU Electronic Library. – Access mode: 

https://elib.bsu.by/handle/123456789/213996 – Access date: 09.09.2024. 

The EEMC on “GIS in Mineral Resource Management” is intended for teachers, 

students, graduate students, undergraduates studying geological and geographical 

sciences. 

The EEMC "GIS in Mineral Resource Management" reveals the methodological 

foundations for organizing geological exploration for minerals, obtaining source 

materials and their theoretical processing. 

The subject “GIS in Mineral Resource Management” reveals research methods 

and the general theory of the occurrence of geological and geodynamic processes in 

the study area. The methodological foundations of regional geology and geodynamics, 

applied and fundamental problems of the placement and use of mineral resources are 

considered. 

All laboratory works, considered below were tested with the QGIS release 3.34.6. 

The package QGIS is freely available to download in Internet. It was released under 

the terms of the GNU General Public License (GPL). It means that the software is free 

and freely adaptable. Several times a year new releases of it become available. Most 

releases were developed to install under several platforms including Windows. 

The algorithm and source data (shape files, Excel data, test maps, etc. were used 

from [11] with minor modification or some additions.  
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1. THEORETICAL SECTION 

LECTURE NOTES 

1.1. Introduction 

Geological exploration of various types of mineral raw materials requires 

sufficient knowledge about the geological evolution of regions, the causes and features 

of geological processes, the conditions for the formation of various minerals in the 

bowels of the Earth in all its shells in the context of the development of our planet over 

time. This science actually studies both random and systemic geological processes and 

their manifestations. 

Minerals provide the material used to make most of the things of industrial-based 

society, for instance, roads, cars, computers, fertilizers, etc. [1 – 9]. Demand for 

minerals is increasing worldwide as the population increases and the consumption 

demands of individual people. The mining of Earth’s natural resources is, therefore 

accelerating, and it has accompanying environmental consequences. The development 

of industrial production steadily requires the expansion of the mineral resource base in 

all regions of the world. 

A mineral is a pure inorganic substance that occurs naturally in the Earth’s crust. 

All of the Earth’s crust, except the rather small proportion of it that contains organic 

material, is made up of minerals; they originate in the process of geologic evolution 

and transformations of rocks. Main types of them are igneous, sedimentary and 

metamorphic rocks. Some minerals consist of a single element such as gold, silver, 

diamond (carbon), and Sulphur. 

More than two-thousand minerals have been identified and most of these contain 

inorganic compounds formed by various combinations of the eight elements (O, Si, Al, 

Fe, Ca, Na, K, and Mg) that make up 98.5% of the Earth’s crust. The industry depends 

on about 80 of the known minerals. Sometimes hydrocarbons and water ice also are 

considered as minerals. 

A mineral deposit is a concentration of naturally occurring solid, liquid, or 

gaseous material, in or on the Earth’s crust in such form and amount that its extraction 

and its conversion into useful materials or items are profitable now or may be so in the 

future. Mineral resources in most cases are non-renewable and include metals (e.g. 

iron, copper, and aluminum), and non-metals (e.g. salt, gypsum, clay, sand, 

phosphates).  

Minerals are valuable natural resources being finite and non-renewable. They 

constitute the vital raw materials for many basic industries and are a major resource for 

development. Management of mineral resources has, therefore, to be closely integrated 

with the overall strategy of development; and exploitation of minerals to be guided by 

long-term national goals and perspectives. 
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There are three main groups of minerals: metallic, non-metallic and energy ones. 

In turn, metallic minerals are divided into ferrous (iron ores, manganese, nickel, cobalt, 

etc.), non-ferrous (copper, lead, tin, bauxite, etc.), precious (gold, silver, platinum, 

etc.). Mica, salt, potash, Sulphur, granite, limestone, marble, sandstone, etc. comprise 

the non-metallic group. Coal, petroleum, natural gas belong to energy minerals. Some 

minerals, like gold and diamond, are rare and precious, while others, like quartz, are 

more ordinary. 

Minerals grouped also by their chemical composition. Silicates, oxides, sulfates, 

sulfides, carbonates, native elements, and halides are all major mineral groups. Many 

minerals play important role for industry. 

Different types of mineral resources require using of different methodological 

techniques for conducting geological exploration, as well as different methods for their 

development and obtaining the final mineral. For example, excavators and large trucks 

are necessary to extract coal after stripping operations in quarries. In contrast, seismic 

surveys are required to identify potential traps for hydrocarbon accumulations, and 

deep wells are required to extract such minerals. Special dredges usually used to extract 

gold from placers in alluvial deposits of river valleys, etc. 

In each specific case, a lot of specialized software has been developed for 

computer processing and analysis of the received data. For instance, for oil exploration 

and recovery they are “Petrel”, “FieldPro” and others”. The “NETPROMine“ mining 

and geological software, covering a number of modules: Geology, Open Pit Mining 

and Underground Mining are used to model processes estimate of resources and 

creating of quarries for extraction of solid mineral resources, etc. However, the 

geographic information systems (GIS software) along with this, other software 

resources are widely used in the practice for prospecting and exploration of mineral 

deposits for mapping, statistical data processing, constructing maps, profiles and 

sections. It depends on the kind of mineral resource, on their occurrence and the 

extraction technology, on assessing recoverable mineral reserves, etc. 

This guide “GIS in Mineral Resource Management” is based on processing the 

latest data on practical and theoretical components of research methods (discussed in 

both parts), general and specific issues of an application of the GIS software. In 

particular spatial systems that creates, manages, analyzes, and map all types of data for 

the sphere of mineral resources, their geological exploration, mapping resource 

deposits, methods of their development and relater tasks. 

 

1.2. Structure and content of the “GIS in Mineral Resource Management” 

 

There are several program packages frequently used in practice: ArcGIS, 

QGIS, Oasis Montaj [16], MapInfo, Adobe Illustrator, Generic Mapping Tools 
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(GMT), Surfer [17, 18], Corel Draw, Grapher, NETPROMine, etc. The packages 

GMT and QGIS are freely available in Internet. They are the fast-growing open 

source geographic information systems and released under terms of the GNU 

General Public License (GPL). It means that they are free to download and freely 

adaptable. Several times a year new releases of them become available. Some of 

them can be installed under several platforms. For instance, QGIS [11] and GMT 

[10] are available free for installation under Windows, macOS, Linux, FreeBSD, 

and Cygwin (a Unix-formatted operating system). The Cygwin can coexist with 

Windows on a personal computer or laptop. Other software products are commercial 

ones.  

The course “GIS in Mineral Resource Management” consists of sections covering 

the following issues: 

1. Mineral Resources: Definition, Types, Use and Exploitation (part 1) 

2. Main GIS software used for development and analysis in Mineral Resource 

Management (parts 1) 

3. Generic Mapping Tools (GMT) Introduction and Definitions (part 1) 

4. Golden Surfer [19, 20] (part 1) 

5. Oasis montaj (part 1) 

6. Laboratory tests based on GMT (part 1) 

7. QGIS Introduction and Definitions (part 2) 

8. Laboratory tests based on QGIS (part 2) 

 

1.3. QGIS Introduction and Definitions 

 

QGIS is a powerful, full-featured GIS widely used in the scientific field [12, 

13]. It allows you to create professional-quality graphics. QGIS is one of the fastest 

growing open source geographic information systems. QGIS is released under the 

terms of the GNU General Public License (GPL). It means that it is free to download 

and freely adaptable. Several times a year new releases of QGIS become available. 

This tutorial provides the information on the QGIS software package and 

instructions for performing basic operations in QGIS. Developers periodically upload 

to their server new versions with enlarged capabilities. The latest basic release (as for 

January 2024) is QGIS 3.36 (e.g., its setup file for QGIS-OSGeo4W-3.36.3 has 1.2 

GBytes). We will consider it capabilities using one of its simpler stable releases QGIS 

3.34 Prizren as an example. Its distribution is available free at the URL: 

http://www.qgis.org/ru/site/forusers/download.html (file QGIS-OSGeo4W-3.34.6.msi 

-Setup-x86 which is only 1 240 260 MBytes) or from any nearest site, e.g. 

https://qgis.org/ru/site/forusers/download.html. It is less sophisticated and provides the 

familiarization with main elements of the QGIS interface when working with shape 

http://www.qgis.org/ru/site/forusers/download.html
https://qgis.org/ru/site/forusers/download.html
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files, loading vector data into the project, visualization and study of spatial data in the 

QGIS. The installation runs smoothly and no additional alignments are necessary. 

Laboratory works [11] aimed at studying the interface and basic capabilities 

of the QGIS [12], performing georeferencing of raster images, creating and editing 

vector objects and their attributes, building surfaces, conducting vector and raster 

GIS analysis, and creating map layouts using GIS tools will be considered in the 

practical section below. 

 

1.7.1. Main characteristics of QGIS 

 

QGIS uses spatial data to compile maps. Each piece of data will also contain 

non-spatial data known as attribute data. Attribute data is generally defined as 

additional information about a spatial feature, for example, a government building. The 

actual location of the government building is the spatial data. The attribute data 

includes the building name, the number of floors in the building, the government 

departments that use the building, when it was built, etc. QGIS includes a number of 

layers having different information, fig. 1. 

 
Figure 1. – Different layers of the same area [13, modified] 

 

A Vector layer. A representation of the world using points, lines, and polygons. 

Vector layers are useful for storing data that has discrete boundaries, such as country 

borders, land parcels, and streets, fig. 2. 
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Figure 2 – Points, lines and polygons [13] 

 

Raster layers. A spatial data layer that is in the form of an image with pixels. 

The image is made up of equally sized pixels (or cells) arranged in rows and columns, 

fig. 3. Each pixel contains an attribute value and location coordinates. Groups of cells 

that share the same value represent the same type of geographic feature, fig. 4.  

 

 
Figure 3 – A raster grid [13, modified 

 

 
 

Figure 4. – Areal image (raster), Port Vila, Vanuatu [13] 
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Main terminology used [13]: 

Attribute. An information about a spatial feature. For example, attributes about 

a school may include the name, level of education, and number of students. 

Coordinate system. A coordinate system is a reference system used to represent 

the locations of geographic features, imagery, and observations such as GPS locations 

within a common geographic framework. 

Scale. A level of resolution or zoom. The relationship between the size of the 

map and the corresponding size of the real world. 

Shape file (*.shp). A type of vector data storage format for storing the location, 

shape, and attributes of geographic features. Each shape file relates to a specific feature 

class i.e. the Roads shape file only contains information on roads. 

Symbology. Conventions or rules that define how geographic features are 

represented by symbols on a map.  

Query. In GIS, a request to select features or records from an attributes table 

based on user-selected criteria to display only those features or records that meet the 

criteria. 

Quantum GIS project started in 2002. Now QGIS is free and open source 

Geographic Information System (GIS) application that allows users to create spatial 

datasets, manage, analyze and display them on a map or another plot. It comes with the 

right to download, run, copy, alter, and redistribute the software. It is multi-platform 

and can run in Windows, OSX, UNIX and UNIX-compatible operational systems, such 

as Linux, Cygwin and others. It is extendable, many of its functionalities are provided 

by plugins and scripts. 

It permits: 

• Adding Vector and Raster layers 

• Adding tabular information as a Delimited text Layer 

• Symbolizing vector data 

• Symbolizing raster data 

• Installing plugins 

• Querying data 

• Joining tables 

• Introduction to the Processing toolbox 

• Map Layouts  

The QGIS interface shown in fig. 5.  
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Figure 5. – The QGIS interface [13] 

 

Some panels could be rearranged to better suite you need. For example, the 

QGIS interface for the release 2.18 could look like this, fig. 6: 

 

 
 

Figure 6. – The QGIS interface [12] 

 

Typically, the QGIS work area has seven parts; 

• Menu Options 

• Toolbar 
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• Map Canvas 

• Browser 

• Table of Contents 

• Tool Box 

• Status Bar 

 

Menu Options, fig. 1.7 

 

 
 

Figure 7. – Menu Options [13] 

 

The Menu Options bar provides access to various QGIS features using a standard 

hierarchical menu (drop down menu). Most menu options have a corresponding tool in 

the Toolbar, fig 8 and Tool Box; however, the menus are not organized exactly like the 

toolbars and may contain additional tools. 

 
 

Figure 8. – Toolbar  

 

The Toolbar provides an access to most of the functions found in the menu 

options bar, plus additional tools for interacting with the map canvas. Each Toolbar 

item has pop-up help available. Hold your mouse over an item and a short description 

of the tool’s purpose will be displayed. 

Below is a view of the Managing Layers Toolbar, fig. 9. 

 

 
 

Figure 9. – Managing Layers toolbar [13] 

 

The Managing Layers Toolbar contains frequently used tools relating to GIS 

layers. The two symbols circled in red represent the ‘add vector layer’ tool and the ‘add 

raster layer’ tool, which will be most commonly used to bring data into the QGIS 

document. 
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Parts of the Toolbar can be moved around according to your needs. Additionally, 

parts of the Toolbar can be switched on/off. Hold the mouse over a blank spot on the 

Toolbar and click the right mouse button to see the context menu, which allows you to 

turn on/off tools. 

If you have accidentally hidden all your Toolbars, you can get them back by 

choosing Menu Options – View – Toolbars 

Map Canvas. The Map Canvas is the main part of QGIS – this is where the 

maps are displayed. The map displayed in the window will depend on the vector and 

raster layers you have chosen to load. The Map Canvas can be panned, shifting the 

focus of the display to another part of the map. The map can also be zoomed in and 

out. Various other operations can be performed on the map using the Toolbar. The 

Map Canvas and the Table of Contents are tightly bound to each other – the maps in 

Map Canvas reflect changes you make in the Table of Contents area. 

Zooming the Map with the Mouse Wheel. You can use the mouse wheel to zoom 

in and out on the map. Place the mouse cursor inside the map area and roll the wheel 

forward (away from you) to zoom in and backwards (towards you) to zoom out. The 

zoom is centered on the mouse cursor position.  

Table of Contents. The Table of Contents area lists all the layers in your map 

project. Click on a check box to turn a layer on or off. Double click on a layer in the 

legend to customize its appearance and set other properties (e.g. appearance of 

symbols, labels). A layer can be selected and dragged up or down in the Table of 

Contents to change the Z-ordering, which means that layers listed nearer the top of the 

Table of Contents are drawn over layers, listed lower down in the Table of Contents. 

Tool Box, fig. 10. 

 
 

Figure 10. – Processing Toolbox [13] 
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The Processing Toolbox, which contains geoprocessing tools, used for creation 

and analysis of both vector and raster data. As mentioned before, some of these tools 

will also be available in the Menu Options as well.  

Status Bar. The Status Bar shows you the current position of the mouse pointer 

in map coordinates 

(expressed as decimal degrees or meters) as well as the map scale and coordinate 

system. As you move the mouse pointer across the map view, the coordinates will 

change. As you zoom in and out of the map, the scale will change. 

Adding Vector Datasets in QGIS. To start working with a map, we need load 

source data. Vector data is arguably the most common kind of GIS data. It describes 

geographic data in terms of points, which may be connected into lines and polygons. 

Every object in a vector dataset is called a feature, and is associated with data that 

describes that feature. The raster data are also used when constructing QGIS maps. 

QGIS can support a number of different vector data formats. These include ESRI 

Shape files and MapInfo TAB files, all of which can be used in QGIS in their current 

formats. We will mostly be using ESRI Shape files in QGIS tests below. 

Map projections 

Geographic Coordinate Systems [11] 

• Defines locations on spherical model of the Earth 

Projected Coordinate System 

• Defines locations on flat model of the earth, fig. 11. 

 

 
 

Figure 11. – Geographic and projected coordinate systems in QGIS [12] 

 

Projected Coordinate System is shown below and can be easily changed, figs. 

12 – 14 [12]. 
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Figure 12. – Changing the projection of the QGIS Map View (step 1) 

 

 
 

Figure 13. – Changing the projection of the QGIS Map View (step 2) 
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Figure 14. – Changing the projection of the QGIS Map View (step 3) 

 

1.7.2. Brief comparison between QGIS and ArcGIS 

 

QGIS is free. Open-source, source codes are open for everyone to modify to 

particular needs. Huge support on forums like stack exchange. Many supported data 

formats thanks to GDAL/OGR library. High functionality for vector and raster 

operations through plugins. Easy integration with other open source software such as 

GRASS or SAGA. 

ArcGIS Commercial – Not freely available. 

License is restricted. 

Source codes not available for users. 

Huge support on ESRI forums. 

More restricted data formats, preference for ESRI created data formats such as 

shape files and grids. 

Higher functionality, especially spatial analysis, and more reliable results than 

QGIS for some of them. 

Designed as a single, stand-alone platform. 

 

The ArcGIS [14] is a powerful software and usually is delivered to students as a 

separate course, therefore very scarce information is given below on this software 

package and we do not plan laboratory tests for this section. 

Maps provide a powerful mean to define and standardize how people use and 

interact with their geographic/geologic datasets. Interactive maps [21] provide the main 
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user interface for most GIS applications. Modern ArcGIS software aimed to perform 

numerous tasks, including advanced data compilation, cartography, analysis, query, 

and field data collection. 

GIS users pan and zoom interactive maps, where map layers apply symbols 

based on a set of attributes and perform query and analysis of operations through the 

map layers. Parcels can be filled with colors based on their zoning types, or the size of 

point symbols for oil or gas wells can be specified based for instance on their 

production levels. GIS user can point to a geographic object in an interactive map to 

get information about the object. ArcGIS users can edit data and feature representations 

through interactive maps. 

Geographic datasets can represent raw measurements (for example, satellite 

imagery), information interpreted and compiled by analysts (for example, roads, 

buildings, and soil types), or information derived from other data sources using analysis 

and modeling algorithms. 

The GIS includes a rich set of tools to work with and process geographic 

information. This collection of tools is used to operate on the GIS information objects, 

such as the datasets, attribute fields, and cartographic elements for printed maps. 

Together, these comprehensive tools and the data objects on which they operate form 

the basis of a rich geoprocessing framework [15]. 

Geoprocessing is used to model how data flows from one structure to another to 

perform many common GIS tasks – for example, to import data from numerous 

formats, integrate that data into the GIS, and perform a number of standard-quality 

validation checks against the imported data, as well as perform powerful analysis and 

modeling. The ability to automate and repeat such workflows is a key capability in a 

GIS. It is widely applied in numerous GIS applications and scenarios. 

 

2. PRACTICAL SECTION  

QGIS examples of laboratory works [11] 

2.1. Laboratory work 1. QGIS basic techniques 

 

The purpose of the laboratory work: familiarization with the main elements 

of the QGIS interface, loading vector data into the project, visualization and study of 

spatial data in QGIS. 

Initial data: 

● shapefile containing the border of the Minsk region (Minsk_region. shp); 

● shapefile containing the boundaries of the administrative districts of the Minsk 

region (district_Minsk_reg.shp); 

● shapefiles containing the river network (rivers_Minsk_reg.shp) and lakes of 

the Minsk region (lakes_Minsk_reg.shp); 

● shapefile of cities in Minsk region (town_Minsk_reg.shp). 
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Laboratory progress 

 

Step 1. Launch GIS QGIS basic techniques via Start Menu → All Programs → 

QGIS 3.34.6 → QGIS Desktop3.34.3 with GRASS GIS 8.3.2. Familiarize yourself with 

the basic elements of the QGIS interface. The working window of the program (fig. 1) 

consists of five main areas: 

1. Main Menu - Provides access to all QGIS features in a standard hierarchical 

menu. 

2. Toolbars provide access to most of the same functions as the menus, and also 

contain additional tools for working with the map. Toolbars are floating. In addition, 

each toolbar can be added/hidden using the context menu, fig.15. 

 

 
 

Figure 15. – Basic elements of the QGIS interface  
 

3. The legend contains a list of all project layers. Each layer displays its name, 

geometry type, and legend. The check box next to each legend item is used to set 

visibility. The order of the layers in the legend determines the order in which layers are 

displayed on the map. Layers at the top of the list will appear on top of layers at the end 

of it. 

The toolbar located at the top of the legend contains the following controls:   

Add group (of layers),  Manage map themes,  Filter the legend by map content;  

Expand All;  Collaps All;  Remove Layer/Group. 

4. Map area. The most important part of QGIS is where the cartographic image is 

given. The latter is determined by the layers loaded into QGIS. The data in the map 

window can be panned (scrolled, shifted the map focus to another area) and scaled. 

5. The status bar displays the cursor position on the map in current coordinates or 

coordinates of the map display boundaries when zooming and panning, the map scale. 

The scale can be selected from a list of preset values from 1: 500 to 1: 1,000,000. 

There is a small checkbox on the right side of the status bar, that allows you to 

stop drawing layers in the map window. Last on the right side of the status bar is the 

EPSG code of the current coordinate system and the Coordinate Transformation icon. 
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One of the advantages of QGIS is a flexible, easily customizable interface. You 

can configure the settings using the Interface settings dialog box (Settings → Interface 

Customization…), fig. 16. 

 

 
 

Figure 16. – Customization the Interface 

 

The session state in QGIS is called a project. You can only work on one project 

at a time. You can save the state of your session in a project file using the menu item 

Projects → Save (or Save as...). Information stored in a project file includes added 

layers, layer properties including symbology, project coordinate system, last map 

coverage, etc. The project does not contain the data itself; it only stores references to 

them. The project file is saved in XML format with a *.qgs extension. 

Step 2. Loading vector data. Using the Layer → Add Lauer →  Add vector 

layer tool, fig. 17, add the following vector layers to the project from the source data 

folder: "Minsk_region.shp", "district_Minsk_reg.shp", "lakes_Minsk_reg.shp", 

"rivers_Minsk_reg.shp", "town_Minsk_reg.shp".  

 

 
 

Figure 17. –Add Vector Layer steps 
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When uploading, select UTF-8 from the encoding drop-down list on the panel 

“Data Source Manager”. By default, it can be Automatic. If you open the file in the 

wrong encoding, then for instance, Cyrillic (Russian) letters (CP1251) will be 

unreadable there. In this case, you need click on Automatic to open the list of encodings 

and set the UTF8 in the layer properties, fig. 18. The Add vector layer dialog box can 

be called also by the key combination Ctrl + Shift + V, or click the  button. 

 

 
 

Figure 18. – Panel Data Source Manager | Vector 

 

Data can also be added to a project directly from the Browser. Browser is a 

floating panel in QGIS that allows you to navigate through catalogs and manage 

geodata. To activate the Browser, you call the context menu in an empty place on the 

toolbar and turn on the corresponding checkbox, fig. 19. 
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Figure 19. – Activating the Browser 

 

In the Browser window, navigate to the source data folder and select the 

"town_Minsk_reg.shp" layer. Add a layer to the project by clicking the Add Selected 

Layers  icon. You can also load data by dragging the selected layer to the map area 

or legend, fig. 20. 

 
 

Figure 20. – The Browser window 
 

Step 3. Create a group of layers. Layers can be combined into groups, including 

nested ones, creating a complex hierarchy and building your own data organization logic. 

In the Layers window, click on the Add group icon. Right-click on the group added 

to the list of layers and in the context menu that opens, select Rename Group, type 

Hydrography. Drag the "lakes_Minsk_reg" and "rivers_Minsk_reg" layers into the 

created group. 
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Step 4. Change the project coordinate system. In QGIS, the project's coordinate 

system is determined by the coordinate system of the first layer you add. Define the 

coordinate system of the current project. To do this, in the Projects menu, select 

Properties and go to the CRS (Coordinate Reference System) tab. The project 

coordinate system is set to WGS 84. Click Hide deprecated CRSs. In the list of 

coordinate systems, select Rectangular coordinate systems - WGS 84 / UTM zone 35N, 

fig. 21. Click Apply and OK. 

 

 
 

Figure 21. – Project properties | Coordinate Reference System selecting 
 

Thus, you have changed the project coordinate system, but the layers continue 

to be stored in the original shape, different from the project coordinate system. QGIS 

supports on-the-fly reprojection or automatic transformation of data from a known but 

different coordinate system from the project to the project coordinate system. On-the-

fly reprojection does not change the CRS of the layer itself, but transforms it into the 

specified one only on the basis of known parameters. 

Step 5 Change the names of the layers. The name of the added layer inherits the 

name of the data source. You can give the layer a more meaningful name without 

changing the name of the source. To do this, right-click on the layer name in the Layers. 

From the context menu that appears, select Properties. On the Layer Properties dialog 

box, in the Layer name field, Rename Layer of the vector layer "Minsk_region" to 

"Border", "district_Minsk_reg" to "Districts", "rivers_Minsk_reg" to "Rivers", 

"lakes_Minsk_reg" to "Lakes" , "town_Minsk_reg" - to "Towns", fig. 22. Click OK. 
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Figure 22. – Layer properties selecting "Rename Layer" 

 

Step 6. Symbolize the layers. Сlick the layer name "Border" with the right mouse 

button. In the Layer Properties window that opens, select the Symbology tab. The 

rendering type is set to Single Symbol (  icon). The Single symbol drawing is used to 

display all features in a layer with a single user-specified symbol. In the preview 

window of the current state of the symbol, select the second level of the symbol (Simple 

fill). Set the following parameters: Fill color – no fill, Stroke style – Dash Line, Stroke 

width – 0.86 millimeters. Select e.g. a dark gray stroke color. Click Apply and OK.  

Symbolize the "Towns" layer with a Simple Fill, the fill color is brown. Display 

the "Rivers" layer in blue with a width of 0.3 mm. Lakes are a Single Symbol (  icon), 

the fill and stroke colors are blue, fig. 23.  
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Figure 23. – Layer properties – symbology panel 

 

In the Symbology section, check the box next to the Draw effects option and 

click the icon  Customize Effects (fig. 24). The Effect Properties panel pops up 

after you click the icon . Perform the setup as shown in fig. 25. 

 

 
 

Figure 24. – Rendering – effect properties 
 

For the "Districts" layer in the Layer Properties window, on the Symbology tab 

as rendering type, specify Categorized (  icon). This type is used to symbolize all 

objects of the layer with a single symbol, the color of which reflects the value of the 

element's selected attribute. Click on Down arrow in the Value row and select abc 

NAME. For the Color ramp set option select Random Colors and click the Classify 

button. Switch off an extra item (all other values) of symbols. Click Apply and OK 

(fig. 25). 
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Figure 25. – Layer properties – Districts – Symbology 
  

Step 7 Arrange the added layers as shown in fig. 26. To do this, in the table of 

contents, select and drag the layer up or down. 

 

 
 

Figure 26. – General view of the Minsk region with classified districts 

 

Step 8. Navigation in the map area is carried out using the tools of the Tools 

panel for moving around the map. When you place the mouse cursor over any button, 
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a small pop-up window will appear with a prompt for the purpose of this key, for 

example “Zoom In” as shown in fig. 27. 

 

 
 

Figure 27. – Tools panel for moving around the map 

 

If a definite toolbar is not in the toolbar area, then enable it using the command 

View → Toolbars → Tools. Tools allow you to reduce or enlarge the scale of spatial 

data loaded into the project; move the image; create bookmarks and manage them. You 

may experiment to move and scale tools. 

Step 9. Creating a bookmark. Spatial bookmarks allow you to create unique 

geographic location markers and return to them later. 

Pan and zoom the map to get closer to the Myadel (Мядель) district. Right click 

the Show Spatial Bookmarks  button or press Ctrl + Shift + B. Select the Spatial 

Bookmark Manager Panel. In the window of the spatial bookmark panel that appears, 

click the Add Bookmark  button to add/change the name of the bookmark to "Myadel" 

(Мядель), fig. 28. The Spatial Bookmarks panel allows you to view or delete 

bookmarks. 

 

 
 

Figure 28. – A panel of the Spatial Bookmark Manager 

 

Navigate to the full extent of the map by clicking  Zoom Full. To return to a 

bookmark in the Spatial Bookmarks panel, with the entry selected, click the  Zoom 

To Bookmark icon. You can also view a bookmark by double-clicking on it. 

Step 10. Each feature on the map is associated with a specific row in the attribute 

table. Explore the attribute table of the "Towns" layer. To do this, right-click on the 

layer name in the legend and select Open Attribute Table. After that, the features table 

of this layer will appear, fig. 29. The number of features is indicated in the header of 

the attribute table. In this case, the total number of objects is 24, of which ‘0’ are 

selected. 
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Figure 29. – Panel of towns and their features 

 

The panel at the top of the features table window includes tools that allow you 

to add (remove) an object or field, perform sorting, filtering, form a selection of objects, 

calculate the field value based on existing attribute values or specified functions, etc. 

Click the  (Select Features Using an Expression) button on the toolbar in the 

attribute table window. In the Select by expression dialog box that appears, you 

compile an expression to sample your data. In the middle section of it, select the Fields 

and Values section to open a list of available attributes. Double-click the attribute 

"INHABITANT" in the list to add it to the Expression field. Expand the Operators list 

and double-click on the ">" (greater than) symbol. A logical operator is added to the 

query text block. In the same place, type 40. Click Select Feature and Close in 

succession, fig. 30. 

 

 

 

Figure 30. – Panel of Cities – Select by expression – towns 

 

In accordance with the condition of the expression you compiled, there will be 

selected cities with a population of more than 40,000. In the drop-down list at the 

bottom left of the attribute table window, select “Select Features”. Only selected 
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objects will be displayed in the attribute table Cities – Features. Click Close the 

attribute table window. You’ll see selected cities, some of them are shown in fig. 31. 

 

 
 

Figure 31. – An example of highlighted selected cities 
 

Step 11. Let's save the selected objects in a separate layer. For this in the Layers 

panel, right-click on the layer name "Cities". From the menu that appears, select Export 

→ Save Features As... Save to your working folder under the name "city.shp", fig. 32. 

Enable Options Save only selected features and Add saved file to map. Rename Layer 

“Towns” (see Step 5) to “Large Cities” (Layer Properties → Source). 

 

 
 

Figure 32. – Save Vector Layer As… panel 

 

Step 12. Classify the cities (large cities layer), once divided into three classes by 

population 40–100, 101–1500, 1501 and higher. On the Symbology tab of the Layer 

Properties – Large Cities dialog box, set drawing style – Graduated symbol (  icon), 
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Value – INHABITANT, click an arrow in the line Color Ramp, then All Color Ramps 

and select Color map – OrRd, as shown in fig. 33. Select Classes – 3, Mode – Equal 

intervals.  

 

 
 

Figure 33. – Selecting OrRd color option panel 

 

Double click on the class borders (click sequentially Values, then Legend tabs) 

and manually change values of the ranges. Adjust the legend as shown in fig. 34. Click 

Apply and OK. 
 

 
 

Figure 34. – Layer properties – Large cities divided into 3 subclasses 
 

Step 13. Place the "Cities" layer below the "Large Cities" layer and set the Scale 

Dependent Visibility (Layer properties → Rendering) so that at full extent the objects 
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in the "Cities" layer are not visible, and when the map is enlarged to several times – 

appeared; the “Large Cities” layer disappeared at the same magnification, fig. 35. 

 

 
 

Figure 35. – Layer properties / Cities – Rendering | Scale Dependent Visibility 

 

After you set the range of visible scales, the layer does not will be displayed if 

the map scale is out of range. The legend will show an unselectable  checkbox. 

Step 14. In the "Rivers" layer, we will display only permanent watercourses. To 

do this, select Filter… from the context menu of the layer. In the Query Builder dialog 

box that appears, you build an expression to fetch your data. The simplest form of an 

expression should consist of a field name (selected from the Fields block on the left 

side of the window), a logical operator (selected using the buttons in the center of the 

window), and a value. In order for the values to appear, it is necessary to press the 

Sample button with the selected field and double click “Постоянная” (Permanent).  

In the field list, double-click TYPE_RIVER to add that field to the query text 

block. Click the tab "=" (equal to) in the Operators group. Click the Sample button and 

double-click Constant item in the Values list, fig. 36. 
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Figure 36. – Rivers and their types 
 

Click OK. In accordance with the terms of your expression all non-permanent 

streams will no longer be displayed in the map window. 

Step 15. Label the objects of the "Cities" layer. On the Labels tab in the Layer 

Properties dialog box, select Single Labels. Set the field OWN_NAMES in the Value 

list. Go to the Text group and specify the Font field – Times New Roman, Size 10. 

Then in the Placement group, select Left sector, fig. 37. 

 

  
 

Figure 37. – Layer Properties – Towns – Labels 

 

Label the objects of the "Large Cities" layer in red, in Times New Roman font, 

size – 12. Placing Mode for labels ode –at the top right of the center of the polygon. In 

result the map looks like in fig. 38.  
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Figure 38. –Labels of towns and cities 

 

Step 16. Create labels for the objects of the "Lakes" layer. On the Labels tab of 

the Layer Properties dialog box, select Single Labels. Set the Value field to 

OWN_NAMES. The color of the labels is blue, the font is Times New Roman, and the 

size is 8. Placing labels Mode – Offset of Centroid. In the Rendering group, select the 

Visible to scale check box. Specify the scale for the appearance of inscriptions the same 

as for the "Cities" layer, fig. 39.  

 

 
 

Figure 39. – Layer properties Lakes – Labels panel 
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Step 17. Create labels for the objects of the "Rivers" layer, for this, select  

Labels from the Layer Properties menu. In the menu select the Single Labels option. 

Set the label field to OWN_NAMES and symbolize the labels: Font – Times New 

Roman, style – Italic (курсив), size – 7, color – Blue. In the  Placement group – 

Mode – select Curved. In the Rendering group, check elect Scale Dependent visibility 

and Mode – Never Overlap (fig. 40). Click Apply.  
 

 

 

Figure 40. – Layer Properties – Rivers – Label styling 

 

Step 18. Open the attribute table of the "Districts" layer (right-click on the layer 

name in the legend Open attribute table). Click the Edit mode icon at the top of the 

attribute table window. Create a new field in the table by selecting the  New Field 

tool. In the Add Field, specify Name – Density, Type – decimal number (real), Length 

– 5, Precision – 2, fig. 41. A field size of 5 with a precision of 2 means that a three-

digit number, a decimal point, and 2 decimal places specifying the precision can be 

entered in the field. 

 
 

Figure 41. – Add field panel 

 

Calculate the values of the Density field using the field calculator, which can be 

called up by clicking on the  icon (Open Field Calculator) of the corresponding tool. 

The field calculator allows you to perform calculations based on existing attribute 
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values or given functions. In the tool's dialog box, activate the Update existing field 

option. Select the Density field from the drop-down list of the section. In the middle 

section of the window, expand the Fields and Values section and double-click on the 

POPUL field name. Then type * 1000 / and double click on AREA (fig. 42). 

Click OK. The calculated values are added to the Density field. Save changes 

and (  icon), exit the edit mode by pressing the  Toggle Editing icon. Close the 

window attribute tables. 

 
 

Figure 42. – Calculator of fields panel 
 

Step 19. Symbolize the Districts layer with a Graduated ( ) icon over the 

Density field. Gradient - YlOrBr, Number of classes - 3, Mode - natural intervals. 

Customize the display of data values in the legend by setting the number of decimal 

places (Precision 1). In the Rendering group, set the transparency using the slider or 

by typing 25 in the box, as shown in figs. 43, 44. Click Apply and OK. 

 

 
 

Figure 43. – Layer Properties – Districts | Symbology panel 
 

Step 20: Adding a base map (called an underlay) to the QGIS project. To add a 

map, we will use the QuickMapServices module. QGIS has a modular architecture, 
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which makes it easy to add missing functionality to an application. Most of the 

functions in QGIS are implemented as core or external modules. Modules are managed 

using the Plugins Manager and involve downloading, updating or deleting them. 

QuickMapServices is an external plugin and is not included in the basic QGIS package. 

Check if this module is installed. To install (if not installed earlier) the module, open 

the Plugins menu and switch to the Not installed tab, where, either by sorting by name 

or by entering part of the module name in the search bar, find the module of interest. 

Select QuickMapServices from the list of modules and click Install Plugin (fig. 45). 

 

 
 

Figure 44. – Minsk region map view 

 

 
 

Figure 45. – List of modules not installed 
 

After installing the plugin, the QuickMapServices group will appear in the Web 

menu. Also, extension buttons will be added to the web toolbar, fig. 46. 
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Figure 46. – QuickMapServices Toolbar 

 

Click the  QuickMapServices icon and select OSM → OSM Standard from 

the menu that opens. The map will automatically be included in the project as a layer, 

fig. 47. In the legend, the layer is at the end of the list. 

 

 
 

Figure 47. – Minsk region modified 

 

A base map added through QuickMapServices is a special kind of layer whose 

display can be configured through the Layer Properties dialog box. The settings allow 

you to enable/disable smoothing, convert the background to grayscale, adjust 

brightness, contrast, and transparency. 

Today, there are several QGIS extension modules for working with underlays, 

including the OpenLayers plugin, which is automatically installed with QGIS and 

allows you to display data from OSM, GoogleMaps, Yahoo Maps, and other services 

in a QGIS project. 

Delete the "OSM Standard" layer from the project (right-click on the layer name 

in the legend → Delete). 

Step 21 Save the project using the Save As... option on the Project menu. Save 

it in your folder under the name "Minsk_obl". Close QGIS. 
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2.1. Laboratory work 2. Geographical linking of raster in QGIS 

 

The purpose of the laboratory work: to master the basic algorithms for performing 

georeferencing of raster images in QGIS. 

Initial data: 

●  shapefile containing administrative borders of European countries 

(country.shp); 

●  bitmap (raster) linguistic_map.jpg; 

●  scanned topographic maps of Belarus at a scale of 1: 100,000. 

 

Laboratory progress 

 

I. Geolinking of the topographic maps on the coordinate grid 

 

The linking of raster information is its transformation from the coordinate system 

in which it exists to the coordinate system associated with the reference surface or the 

coordinate system of the projection that can be used to solve real spatial problems. 

Geolinking data in QGIS is done using a special module called Raster Anchor (GDAL). 

Step 1. Open QGIS Desktop 3.34.6. Start working with a new empty project 

(Projects → New). Run the Layer menu – Georeferencer as shown in fig. 48. 

 

 
 

Figure 48. – Georeferencer location 

 

Georeferencer panel with an explanation of the toolbar icons shown in fig. 49. 
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Figure 49. – Georeferencer panel with the toolbar icons explanation 
 

Step 2. Load the linked raster file into the data view (the task is performed by 

variants – the variant number corresponds to the number of the computer you occupy, 

the rasters are located in the source data folder).  

1st option - n35-081.jpg (Cherven) 

2nd option - n35-122.jpg (Bereza) 

3rd option - n35-019.jpg (Braslav) 

4th option - n35-066.jpg (Molodechno) 

5th option n35-082.jpg (Berezino) 

 6th option - n35-054.jpg (Vileika) 

7th option - n35-143.jpg (Mozyr) 

8th option - n35-116.jpg (Salihorsk) 

9th option - n35-085.jpg (Skidel) 

10th option - n35-048.jpg (Senno) 

After launching the Georeferencer, a dialog box of the tool will open, divided 

into two parts: a data part and a part of the table GCP of anchor points, fig. 50.  
 

 
 

Figure 50. – Loaded a raster map 
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To add a raster, choose on the panel File → Open raster or use the  Open 

raster icon on its toolbar and load one of raster maps, for instance n-35-066.jpg.  

Click the Start Georeferencing icon , a small pop up panel reminds you 

‘Please set output file name’, click OK, fig. 51. On the panel of Trasformation 

Settings, that appears, select Resampling method –Nearest Neughbour and check  

‘Save GCP points’ and ‘Load in Project when done’. Click the Start CRS icon , 

and click OK, fig. 52.  

 
 

Figure 51. – Georeferencer reminder 

 

 
 

Figure 52. – Transformation Settings panel 

 

In the panel Coordinate Reference System (CRS) Selector, that appears, set the 

following coordinate system: Rectangular coordinate systems Transverse Mercator - 

Pulkovo 1942/GaussKruger zone 5 (linking maps are compiled in this coordinate 

system) and click OK button, fig. 53. 
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Figure 53. – The panel of Coordinate Reference System Selector 

 

We will use the intersection nodes of the kilometer grid as reference points. The 

kilometer grid is formed by a system of lines parallel to the image of the axial meridian 

of the zone (vertical grid lines) and perpendicular to it (horizontal grid lines). The 

distance between adjacent grid lines on maps at a scale of 1:100,000 is 1 cm (1 km). 

The ends (outputs) of the coordinate grid lines near the frame of the map sheet are 

signed with the values of their rectangular coordinates in kilometers. The extreme lines 

on the sheet are signed with the full values of zonal coordinates in kilometers. The rest 

of the grid lines are the last two digits of the coordinate values (abbreviated 

coordinates). 

The labels of the vertical lines indicate the zone number (first digit) and the 

distance in kilometers (three digits) from the origin of coordinates, conditionally 

moved to the west of the middle meridian by 500 km. For example, the signature 5596 

in the upper left corner means: 5 is the zone number, 596 is the distance from the 

conditional origin in kilometers. 

Labels of horizontal lines mean the number of kilometers, on which a particular 

line is offset from the equator. Thus, the point, located at the intersection of the 

kilometer grid lines (5596 and 6170), will have the following coordinates (in meters): 

x = 5,596,000 and y = 6,170,000, fig. 54. 
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Figure 54. – Fragment of a map 
 

Step 3. Increase the extent of the raster using the  Zoom and  Pan tools near 

the top left corner of the topographic map.  
 

Select the  Add point tool, click the cursor at the intersection of the kilometer grid 

lines on the map. In the window that appears, enter the coordinates of the 

corresponding intersection node, fig. 55, they will be added to the GCP table. 

 

 
 

Figure 55. – Fixing coordinates of control points 

 

Using button  Move GCP point button you can move created points, if they 

are not located where you want. Digitize at least four reference points (preferably six 

to eight), which are evenly spaced on the map sheet. 
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After placing the required number of points, the points collection window should 

look like in fig. 56. 

 

 
 

Figure 56. – GCP table with parameters of control points 

 

To save the collected points, in the File menu of the Georeferencer panel, select 

Save GCP points as... or use the icon . They will be saved to an additional file with 

the *.points extension, which has same name as the raster map being linked. The 

content of the file is easy to edit in any text editor. If for some reason the process of 

arranging points had to be interrupted, then the next time the raster is loaded, the placed 

points will be loaded along with it. To load another point file, select File → Load GCP 

Points... at the same panel. A view example of another raster map with 5 points selected 

and the GCP table is shown in fig. 57. 

 

 
 

Figure 57. – A map view with GCP table of 5 control points in degrees-minutes 

(Dest. X – Dest. Y columns) 

 

Step 4 Define the transformation options for the binding. Click Settings → 

Transformation Settings… (  icon) and set the following settings: Transformation 

type – Polynomial 1 or Polynomial 2 (it is recommended to use a polynomial model 

corresponding to the number of created control points); The Interpolation method is 

Nearest Neighbor as it was selected above, if not indicated earlier (see figs. 52, 53). 
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Save the target raster to your folder with a new name (for example, n-35-

066_modified.tif). Target coordinate system – Rectangular coordinate systems 

Transverse Mercator – Pulkovo 1942/GaussKruger zone 5. Activate Load in project 

when done (see fig. 52). Once the transformation is complete, the output raster will 

automatically be loaded into QGIS, fig 58. 
 

 
 

Figure 58. – Map view 
 

Step 6. Using the  Add vector layer tool, load the kilometer grid shapefile 

located in the source data folder (z5gk.shp) into the project to check the alignment 

accuracy, fig. 59. First make sure that in the project properties (Project → 

Properties…) the Pulkovo 1942/GaussKruger zona 5 coordinate system is set. 
 

  

An example of a "good" 

anchor - the anchored map 

matches the computational 

grid (red lines) 

An example of inaccurate 

referencing – the referenced map 

does not match well with the 

computational grid (red lines) 

 

Figure 59. – Checking the alignment accuracy 
 

Close the Georeferencing tool window.  
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II. Georeferencing a raster image by a vector layer 

Step 1. In the QGIS Desktop 3.34.6, create a new project (Project → New). Using 

the  Add Vector Layer tool, load the country.shp shapefile (located in the source 

data folder) into the map area. Specify the coordinate system of the project, to do this, 

in the Projects menu, select Properties and go to the Project Properties – CRS. Selected 

system: WGS 84. 

Step 2 Change the symbology of the "country" layer. Right-click on the layer 

name in the legend and in the menu that opens, select Symbology. In the Symbology 

window, select Simple fill. Set: Fill style – No Brush, Stroke color – red, Stroke 

thickness – 0.6 mm, fig. 60. 

 

 
 

Figure 60. – Layer Properties country – Symbology 

 

Click OK and close the Properties dialog box. 

Step 3. Use the  Zoom In and  Pan tools to enlarge the map extent so that it 

includes Latvia, Belarus, and Ukraine, fig. 61. 
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Figure 61. – Borders of Belarus and neighbor countries 

 

Step 4. Launch the Georeferencer (Layer → Georeferencer). Load a raster layer 

"linguistic map.jpg" into the module data view from the source data folder (File → 

Open raster or click  Open raster). Set the coordinate system of the vector layer 

(Source – Assigned Coordinate Reference System (CRS) – Set CRS) by which set to be 

bound and will be performed (Geographic coordinate systems – WGS 84). To quickly 

find the required coordinate system, you can use the EPSG (European Petroleum 

Survey Group) code, fig. 62.  
 

 
 

Figure 62. – Selecting of the coordinate system 

 

EPSG codes, which are a register of definitions of various coordinate systems and 

transition parameters between them, are stored in a database and can be used to describe 

a projection. 

Step 5 Use the  Zoom in tool to zoom in on the northwestern tip of Belarus. Click 

the  Add Point icon of Georeferencer, the cursor will turn into a crosshair and place 
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it at the junction of the borders of Belarus, Poland and Ukraine and click the left mouse 

button. In the Enter map coordinates window that appears, select From map canvas, 

fig. 63. In the QGIS map area (with the "country", that appears), specify left-clicking 

by your mouse the corresponding intersection of Belarus, Poland and Lithuania 

borders. The X, Y coordinates of the reference point will be added to the GCP table. 

Click OK. 
 

 
 

Figure 63. – Selecting of the coordinate system 
 

Continue entering control points. Use the administrative boundary crossing 

points, characteristic bends of the border lines as reference points. The points must be 

evenly spaced. Set at least 10 control points (required for 3rd degree polynomial 

conversion). Save the checkpoints (File → Save GCP Points As...). 

Step 6. Set the following transformation parameters in Georeferencer (Settings → 

Transformation Settings). The dialogue panel will appear: set there the Transformation 

type – polynomial 2, Transformation type – Cubic (44 Kernel). Define the Output file. 

The Target CRS (target coordinate system) should be set automatically (WGS 84). 

Activate Save GCP points and Load in project when done, fig. 64. Click OK. 

 

 
 

Figure 64. – Transformation settings panel 
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On the Georeferencer toolbar, click the  Start Georeferencing icon. 

Rebind using a 3rd degree polynomial transform type (Settings → 

Transformation settings, then in Transformation Settings panel change the polynomial 

transform type in Transformation Type window). Increase the number of anchor points 

if necessary. 

The alignment accuracy of all control points can be measured mathematically by 

comparing the known location of the point in map coordinates and its position on the 

transformed raster. The distance between locations of these two points is called 

residual error (RMS). In the Control Points window of the Raster Binding module 

(Residual column) you can estimate the error value for each point. The error is 

measured in units of the original coordinate system, i.e. if you refer to a newly scanned 

map, then the transformation error will be expressed in pixels. 

The total root-mean-square (RMS) conversion error is calculated by taking the 

square root of the sum of the squared errors of all links and dividing by the number of 

links. This value shows how different the result of the transformation is from the ideal 

combination of all control points (links).  

To reduce the magnitude of the error, it is generally recommended to eliminate 

the control point with the largest deviation (or replace it). A point should not be deleted 

if its position is confidently determined or if its deletion violates the condition of 

uniform distribution of control points over the entire geoimage. 

Transform the map using the Thin Plate Spline and Projective methods. Create 

and complete the table 1. 

 

Table 1. – Raster transformation 

Transformation Method Total RMS Error Print Screen Map 

2nd order polynomial     

3rd order polynomial     

Thin-walled spline     

Projective method     

 

Figure 65 shows a raster image bound by the 3rd order polynomial 

transformation. As you can see, the map quite accurately coincided with the contours 

of the administrative-territorial division, which, given the initial quality of the 

materials, can be considered a satisfactory solution. 
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Figure 65. – Study region 

 

2.3. Laboratory work 3. Creating a point layer from text data in QGIS. 

Heat maps 

 

The purpose of the laboratory work: to become familiar with the algorithm 

for converting sets of coordinates from various kinds of tables into vector layers of a 

point type and creating ‘heat’ maps in QGIS. 

Initial data: 

● data on the coordinates of tourism objects in the Brest region in MS Excel 

format; 

● shape file containing the boundary of the Brest region 

(Grodno_boundary.shp). 

 

Laboratory progress 

 

I. Creating a point shapefile from text data 

Let us analyze the problem of creating a shapefile from text data using the 

example of creating a vector layer of tourist objects in the Grodno region. 

Step 1. Preparing data for import. The initial data contain information about the 

coordinates of tourist sites in the Grodno region and are presented in the Excel format. 

Open the attraction.xlsx file located in the source data folder in Microsoft Excel. Add 

a numb field and number the objects from 1 to 49. Save as a .csv (comma delimited – 

разделители запятые) text file, fig. 66. CSV is a text format for storing tabular data. 
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Figure 66. – Reformating a xlsx Excel file into csv Excel file 
.1  

Step 2: Open QGIS Desktop 3.34.6. Start working with a new empty project. 

Activate the  Add Delimited Text Layer… tool in the Layer– Add Layer panel. In 

the Data Source Manager | Delimited text dialog box that opens, specify the 

attraction.csv file to be added by clicking the Browse button (or drag-n-drop it from 

the source folder). Check the Custom Delimiters option and select Semicolon. If the 

separators are selected correctly, the data is displayed correctly in the preview area. 

Check that the Xcoordinate field is set to x, and the Ycoordinate field is set to y. Leave 

the rest of the settings as default. Click Select CRS  icon. In the Coordinate 

Reference System Selector, which opens, specify WGS 84. The “attraction” layer will 

appear in data view, fig. 67. Click Add, then – Close. 

 

 
 

Figure 67. – Creating a shape file progress 
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Step 3 Open the attribute table of the "attraction" layer. The full set of values 

from the source database for each point is stored. At the same time, the resulting layer 

is virtual: it is not written to disk and is not available for editing. Save the virtual layer 

as a shapefile. Right-click on the name of the vector layer in the legend, select Save 

as..., fill in the window: using the Browse button, specify the location and name of the 

new file (for example, attraction1.shp), set the project coordinate system to WGS 84. 

Click OK. A new layer will appear, written to disk, available for editing. Delete or 

uncheck the "attraction" virtual layer (right-click on the layer name in the legend → 

Delete). 

Step 4. In the same way, convert the files located in the source data folder 

museum.xlsx and viewpoint.xlsx into point shape files. 

Step 5. Add the "Grodno_boundary" layer to the project (located in the source 

data folder). Move it down in the legend. Symbolize the layer with a Single Symbol (

 icon). Set the Stroke – red, Stroke widths – 0.6 mm, fig. 68.  

 

 
 

Figure 68. – Layer properties – Grodno_boundary Symbology panel 

 

Step 6. Merge shapefiles. From the Vector menu, select Data Management Tools 

→ Merge Vector Layers, fig. 69. 
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Figure 69. – Merging vector Layers option 

 

In the Merge vector layers window on the Parameters tab, click the button Select 

All at the Input Layers line and in the window that opens, select three created shapefiles 

simultaneously (attraction1.shp, museum1.shp and viewpoint1.shp). Click OK, fig. 70.  

 

 
 

Figure 70. – Merging vector Layers option – selecting three files 

 

Save the result of the merging to your folder under the name "poi-point.shp". 

Check the Open output file after algorithm execution option. Press the Run button, fig. 

71. 

 
 

Figure 71. – Progress of merging vector layers 
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A layer called "Merged" will be added to the project, containing features from 

the three source shapefiles, fig. 72. 

 

 
 

Figure 72. – Map with points within Grodno region 

 

II. Creating a Raster Density Map (Heat map)  

A heat map is a raster map that shows the density of point data. Density is 

calculated from the number of points in a certain area, more points gives a higher 

density value. Heat maps make it easy to identify clusters of points and identify "hot" 

areas. Density maps in QGIS are created using several individual modules to create 

"heat maps", for instance: D3 Data Visualization; heatmapplugin; densityanalysis-

2024.1.23. The Density Analysis plugin included in the used QGIS release. 

This plugin automates the creation of density heatmaps in QGIS with a heatmap 

explorer to examine the areas of greatest concentrations. It includes H3, geohash, and 

polygon density map algorithms along with several styling algorithms. It can paste a 

style onto all selected layers. Two options are described below: Option 1 and Option 

2, you may choose one (or both) of them. 

Option 1. 

Step 1. Activate the plugin by selecting Manage and Install Plugins… from the 

Plugins menu. On the Installed tab, check  Density. If it is not installed, then open 

Not Installed, find and install it, fig. 73. After successful installation, several icons will 

be added to the toolbar). 
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Figure 73. – Density Analysis plugin 

 

This plugin adds additional density heatmap algorithms to QGIS including 

geohash, H3, styled heatmap, and polygon density maps. It adds a vector density 

heatmap explorer to examine hotspot areas of greatest concentrations. It wraps the 

QGIS Heatmap (Kernel Density Estimation) algorithm into a new version that 

automatically styles the layer and allows the user to specify the cell size in various 

units of measure and not just the units of the layer's CRS. It provides an algorithm to 

create a raster density of polygons. It has processing algorithms to create a gradient 

style, random style, and raster pseudocolor style so that they can be used in QGIS 

models. Another tool allows a copied style or a .qml file to be pasted onto all selected 

layers. Once installed, the plugin is located under Plugins → Density analysis in the 

QGIS menu, on the toolbar, fig. 74, and can be found in the Processing Toolbox under 

Density analysis, fig. 75. This shows plugin from the main menu with Geohash density 

algorithms expanded.  

 

 
 

Figure 74. – Ten icons created after installation the Density analysis plugin 

 

Details with multi-page description for each of its options can be fined at: 

https://github.com/NationalSecurityAgency/qgis-densityanalysis-plugin?tab=readme-

ov-file. 

 

https://github.com/NationalSecurityAgency/qgis-densityanalysis-plugin?tab=readme-ov-file
https://github.com/NationalSecurityAgency/qgis-densityanalysis-plugin?tab=readme-ov-file
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Figure 75. – Main options of the Density analysis plugin 

 

Step 2. Click the Styled density map  icon to open this plugin. The Styled 

Density Map panel will be open, fig. 76. 

 

 
 

Figure 76. – The Styled Density Map panel 
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At this panel you’ll configure your input and output parameters. Please use the 

created poi-points.shp as the input file, grid type, windows cell width in measurement 

units, cell height in measurement units, select color ramp, and maximum grid width 

on heights and number of gradient colors could be adjustable according your request. 

An example is shown in fig. 76. 

Finally, you’ll select the output density heatmap, for instance as file poi-

heatmap.shp, and click Run. You’ll see the image like shown in fig. 77.  

 

 
 

Figure 77. – An example of the heat map according to parameters set above 

 

You can play with options in the Style Density map panel, see fig. 76 and 

heatmaps with individual colors and shapes. The variety of options of the Density 

Analysis plugin was shown in fig. 75 above. If you like, you can also experience with 

other options besides already considered one (Styled density map) of the Density 

Analysis plugin yourselves (they are: Geohash density algorithms, H3 density 

algorithms, Density map analysis tool, Styled heatmap (Kernel density estimation), 

Styled polygon density (raster), Polygon density (raster), Styled polygon density 

(vector), Polygon density (vector), Apply style to selected layers, Apply graduated 

style, Apply random categorized style, Apply pseudocolor raster style). Details with 

multi-page description for each of its options can be fined at: 

https://github.com/NationalSecurityAgency/qgis-densityanalysis-

plugin?tab=readme-ov-file. 
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Option 2. 

Step 1. There is another frequently used heatmap module (Kernel Density 

Estimation) available in the third QGIS releases, in particular in QGIS 3.34.6. 

To open it click Processing → Interpolation → Heatmap (Kernel Density 

Estimation), fig. 78 and the dialogue panel pops up, fig. 79. 

 

 
 

Figure 78. – Calling up the heatmap module 

 

Step 2. Set the source layer to "poi-point.shp" (the extension is not obligatory) 

from the work folder. Indicate the heat_map.tif in the "Heatmap" window, set "Radius" 

to be 0.30 degrees (you can play with this parameter, as well as with Rows and 

Columns). 

 
 

Figure 79. – Heatmap (Kernel Density Estimation) dialogue panel 
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Check the "Open output file after running algorithm". Radius determines the 

zone of influence of each point. Leave other options as shown in fig. 78. Click Run to 

create and load the heatmap in QGIS. Close the Heatmap dialogue panel. 

Once loaded, the heatmap is displayed in grayscale settings, with low raster 

values representing dark shades and high raster values representing light shades, fig. 

80. 

 
 

Figure 80. – Heatmap raster in dark shades 

 

Step 3. Cut out the resulting raster along the border of the Grodno region. To 

do this, in the Raster menu, select Extraction → Clip Raster by Mask Layer. In the 

dialogue Clip Raster by Mask Layer in the Input layer window select "heat_map" 

(raster) in the drop-down list. In the Mask layer group, select Grodno_boundary.shp, 

other options are shown fig. 81. Click "Run" and "Close". The clipped map looks like 

in fig. 82. 

 

 
 

Figure 81. – Heatmap with raster in dark shades 
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In the Layers panel the Clipped (mask) raster layer (in the GeoTIFF format) 

will be added. Rename it to "POI_heat_map". Now you may deactivate or delete the 

heat_map layer from the project. 

 
 

Figure 82. – Clipped heat map raster in dark shades 

 

Step 4. Change the symbolization of the layer "POI_heat_map". To do this, 

select the layer in the list of project layers, call the context menu with the right mouse 

button and select Properties. Go to the Symbology tab. Change the rendering style in 

the Band Rendering field from “Singleband gray” to “Singleband pseudocolor.” Select 

a suitable color map in the Color ramp field, for example OrRed. Mode – Continuous 

(fig. 83). Click the "Classify" button and adjust the classes of colors, e.g. – 5, then close 

the window and apply the raster display settings, fig. 84. 

 

 
 

Figure 83. – Change the band (grey) for pseudocolor dialog 
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Figure 84. – Raster map in pseudocolor 

 

Step 5. Create your own density maps using a viewpoint shapefile. When 

creating, select the optimal radius parameter. For viewpoint objects, create two heat 

maps using the kernel functions: Triweight one and Epaneshnikov (the kernel function 

can be selected in the corresponding drop-down menu of the Advanced group of the 

Create Heat Map tool). The kernel function specifies an algorithm that calculates the 

decrease in the influence of a point as the distance from it increases. Different functions 

have different reduction factors. Thus, the Triweight function gives more weight at 

small distances from a point compared to the Epaekshnikov function. And as a result, 

the Triweight function makes the “hot” spots clearer, and the Epaneshnikov function 

makes them smoother. 

 

2.4. Laboratory work 4. Creating a tourist map in QGIS 

 

Lab Objective: To learn how to create and edit vector polygonal, line and point 

objects and their attributes, actions and map layouts in QGIS. 

Initial data: 

● scanned and georeferenced map of Zaslavl – georeferenced zaslavl.bmp 

(which is successfully loaded as a raster layer under old QGIS releases, e.g. QGIS 2.18, 

but is loaded not correctly under, QGIS-3 releases). Its converting into tif, jpg, or png 

formats doesn’t solve the problem. Therefore, we’ll use the Zaslawl_region.qgs 

instead (created using QGIS 2.18) the single of which incorporates the raster file 

zaslavl.bmp. 

● shapefile containing the railroad of the Minsk region (railway_Mo.shp); 
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● shapefile of buildings in Zaslavl (building.shp); 

● shapefile of points of interest (POI) of the Minsk region 

(entertainment_Mo.shp). 

 

Laboratory progress 

 

I. Creating point, line and polygon features in QGIS 

Step 1. Open QGIS Desktop 3.34.6. Load the Zaslawl_region.qgs project with 

a single layer, fig. 85.  

 

 
 

Figure 85. – Zaslavl town and adjoining area 

 

Check the coordinate system for loaded image (zaslavl layer → Properties → 

Source → Assign Coordinate Reference System (CRS), it must be: Rectangular 

coordinate systems – WGS 84 / UTM zone 35N – EPSG: 32635, fig. 86. Otherwise, 

correct it. 
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Figure 86. – Checking the coordinate system 

 

Step 2: Create a New Polygon Shapefile for the town boundary (ZaslavlBorder). 

From the Layer → Create Layer → New Shapefile layer… and click it to open the 

dialog panel, fig. 87. You also may use the  icon, by default on the layers panel.  

 

 
 

Figure 87. – Creating new shape file layer 

 

In the dialog box set the required parameters. Firstly, set the geometry type of 

layer being created – polygonal (  Polygon), encoding: UTF-8, additional dimensions 
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– M values. Define the coordinate of the layer: WGS84 / UTM zone 35N. You can 

also define tab fields of the table of attributes. In the Name field, enter its name, in the 

Type field, select integer, decimal, text. To add and remove fields can be changed using 

the  Add to Field List and  Delete field buttons. By default, only the required 

attribute is included in the field list, but "id" (type – Integer, size – 10). This is a unique 

identifier. 

Create a Name text field with a size of 50. Note that the name attribute must be 

written in Latin letters and contain no more than 12 characters. Most field properties 

after table creation, in particular, the field type and size cannot be changed. 

The last step in creating a shapefile is assigning name and select the folder where 

the file will be stored. It is better to assign short and understandable names, such as 

"border", "river", etc. Name with stored shapefile "ZaslavlBorder" and click Save (fig. 

88). 

 
 

Figure 88. – Creating a new shape file polygon layer 
 

After all the necessary parameters have been set, click OK button. 

The newly created layer will appear in the legend of the QGIS project. The layer 

is edited in the appropriate mode using the editing panel tools, fig. 89. 
 

 
 

Figure 89. – Editing tools panel 

 

Step 3. Zoom in the Zaslavl raster map to desired extent to clearly distinguish 

small details along the border line. Now we’ll set the vector layer editing parameters. 

For settings editing options select the Layer properties – ZaslavlBorder settings menu 
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and go to the Digitizing tab. In the dialog box that opens, fill some of digitizing 

parameters. An example is shown in fig.90. Click Apply and OK. 

 

 
 

Figure 90. – Adding digitizing parameters 

 

Step 4: Create a vector polygon feature in the layer "ZaslavlBorder". Switch to 

edit mode. With a dedicated layer legend window, click on the icon  Toggle Editing. 

To add a polygon, click the icon  Add polygon feature and the mouse cursor converts 

into the   symbol. The border of Zaslavl town is shown in the raster map by the red 

dash-dotted line. Starting with any point of the town border line sequentially click the 

left mouse button, specifying vertices, gradually proceed with cursor around the city 

border line and clicking produce series of vertices. Click the right mouse button when 

you finish.  

When vectorizing, if you have reached edges of the map area and you need to 

pan the image to move the visibility boundaries, hold the Space key and move the 

mouse without clicking buttons, then release it. You can Zoom in for more effective 

digitizing is possible also using the mouse wheel. The point that ends polygon input is 

indicated by right-clicking the mouse key.  

If necessary, edit a created polygon, , use the  Vertex tool, which allows you 

to delete nodes or change their locations, add new ones by double click. Exit edit mode 

clicking the  Toggle editing icon a second time. Save (  icon) layer changes. 
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Step 5. Symbolize the "ZaslavlBorder" layer as follows (right-click on the layer 

in the legend window → Layer Properties ZaslavlBorder → Symbology). Set the Move 

slider “opacity” around 25 % for the Single Symbol option (  icon) → Fill. For the 

Simple Fill option use settings as shown in fig. 91. Click Apply and OK. 

 
 

Figure 91. – Settings for ZaslavlBorder layer in Symbology panel 

 

Step 6. Create a new vector layer for Knyaginka river (Layer → Create layer → 

New shapefile layer). The New Shapefile Layer dialog box can also be invoked by the 

keyboard shortcut Ctrl + Shift + N. Geometry type – line string. Layer coordinate 

system: WGS 84 / UTM zone 35N. Additional dimensions – M. In addition to the 

default field with id type integer = 10 characters, add the text fields to the attribute 

table: and Knyaginka – 25 characters. After all the necessary parameters have been set, 

click OK. The new layer Knyaginka will be added, fig. 92.  
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Figure 92. – Creating the vector layer Knyaginka river 

 

Step 7. Start editing the created layer Knyaginka.shp. Zoom in the Zaslavl raster 

layer to be able distinguish small details along the river valley. Toggle editing  icon 

for editing. Using the  Add Object (points) tool, digitize the Knyaginka river located 

on the territory of the raster Zaslavl map. When finishing with its digitizing right-click 

the mouse button and the Knyaginka – Feature Attributes panel pops up, you may leave 

it as is and click OK, fig. 93. Click once more the  and a new Stop Editing panel 

reminding if you wish to save or discard digitizing, click Save button (the  icon). 

 

 
 

Figure 93. – Knyaginka – Feature Attributes panel 

 

Symbolize the "Knyaginka" layer as follows (right-click on the layer in the 

legend window → Layer Properties Knyaginka → Symbology). Set the blue color, 

slider “opacity” leave 100 % at the Line option (  icon), select the Solid line with 

Stroke width – 1.6 for Simple Line option. Other options are shown in fig. 94. Click 

Apply and OK. The created map will look like in fig. 95. 
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Figure 94. – Knyaginka – Symbology panel 

 

 
 

Figure 95. – Finishing the digitized vector layer Knyaginka river 

 

Step 8. Do the same for the second river Chernitsa. Start editing the creating 

layer Layer → Create layer → New shapefile layer. Again, in the dialog panel: 

Geometry type – Line string. Layer coordinate system: WGS 84 / UTM zone 35N. Add 

two text fields to the attribute table: type and Chernitsa 10 and 25 characters 

respectively. Select M values. After all the necessary parameters have been set, click 

OK, similar to fig. 94. The new layer Chernitsa will be added. Digitize it as described 

above for Knyaginka river. Finish digitizing and the symbology in the way, shown 

above for Knyaginka river. Now both layers (Knyaginka and Chertitsa) were added to 

the project.  
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Step 9. Create a new vector layer "Kanal". The similar algorithm will be used 

below for the main canal of the Vileika-Minsk water system to those used for the 

Knyaginka river. Zoom in the raster map, and so on. After finishing digitizing the 

Kanal right-click the mouse button and then click OK at the Kanal layer and open the 

Properties panel, do similar settings in it and save related files (  icon) for the Kanal 

layer. 

Step 10. When three vector files for waterways were created, indicate three 

waterways Knyaginka, Chernitsa and Kanal layers with pressed Ctrl key, add the 

group rivers clicking the  icon on the panel of layers and name it as “Waterways”. 

Layers Chernitsa, Knyaginka and Kanal will be placed below the created group file 

Waterways,  

Step 11. Create a new vector layer "roads" Layer → Create layer → New 

shapefile layer). Layer coordinate system: WGS 84 / UTM zone 35N. Add two text 

fields to the attribute table: type and name 10 and 20 characters respectively. Select M 

values. After all the necessary parameters have been set, click OK, fig. 96. The new 

layer roads will be added. 

 

 
 

Figure 96. – Creating the vector shapefile roads 

 

Step 12. Start editing the created layer roads.shp. Zoom in the Zaslavl raster 

layer to such an extent to be able distinguish small details along the selected street. 

Toggle editing  icon for editing. Using the  Add Object (points) tool, digitize the 

selected street(s) located on the territory of the raster Zaslavl map (similar algorithm 

will be used later for each of main streets). After finishing digitizing the first street 

(left-clicking a number of points) right-click the mouse button and then click OK at 

the roads feature attribute panel. Save your edits by clicking on the Save edits  icon 
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and don’t exit edit mode (don’t click the Toggle editing  icon). Open roads → 

Properties  → Symbology and select the line color – orange, width – 2.60, Opacity – 

100 %. Click Apply and OK. Continue editing (same shapefile roads) with the next 

street. Repeat same algorithm until you’ll finish with all main streets. After saving the 

last street, exit from the Edit mode (click Toggle editing  icon). When you’ll finish 

your work the map Zaslavl and vicinity looks like shown in fig 97. 

 

 
 

Figure 97. – Zaslavl town with surroundings and five vector shapefiles overlaid 

 

The current Layers panel view corresponds to fig. 98. 

 

 
 

Figure 98. – View of the panel “Layers” after adding waterways and roads 
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Step 13. Add the railway_Mo shapefile to the project (located in the source data 

folder) containing the railway roads of the Minsk region. Open the geoprocessing tool 

Clip, fig. 99.  

 

 
 

Figure 99. – Open Clip algorithm 

 

We will cut out the railway along the border of the city of Zaslavl. In the window 

that opens, select as the source of vector layer “railway_Mo” as the cropping layer. 

Save the result in your folder with the name “railway_Zaslawl.shp” (fig. 100). Add the 

created file to the project (check the “Open output file after running algorithm”). 

Deactivate, or delete the layer “railway_Mo” from the project. 

 

 
 

Figure 100. – Clipping the “railway_Mo” layer Zaslavl town border 
 

Step 14. Symbolize the railroad layer with the Single Symbol (  icon). On the 

Symbology tab of the Layer Properties dialog box, click on the first level of the sign 

(Line) and in the Signs group that appears, select Colorfull, Greyscale (fig. 101). 

Change the color of the lines that make up the symbol to black and white. 
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Figure 101. – Symbolizing the “railway_Zaslavl” layer 

 

Step 15. Add a shapefile of the buildings_Zaslavl_prj.shp to the project. Set the 

layer's Drawing type to Single Symbol values, Stroke style – no stroke, Color – to 

brown. 

Step 16. With the Crop geoprocessing tool, you we will complete the cutting of 

the roads layer outside the border of the city of Zaslavl. As above, see fig. 99) activate 

the tool (Vector → Geoprocessing Tool → Clip). 

In the dialogue window, select roads.shp as the Input layer, select the Overlay 

layer – "ZaslavlBorder". For clipped result to your folder type in the Clip window 

"roads_o.shp". To add created file to the project, check “Open output file after running 

algorithm” and click Run button, fig. 102. 

 

 
 

Figure 102. – Clip dialog panel 

 



72  

Symbolize the created shape file roads_o.shp. Open roads_o → Properties → 

Symbology and select the Line color – orange, Width – 1.60, Opacity – 100 %. Click 

Apply and OK. Switch off the layer roads.  

Step 17. Add a point shapefile entertainment_Mo to the project, containing 

some tourist sites in the Minsk region. Clip the added layer along the city boundary 

(Vector → Geoprocessing Tools → Clip). Save the result to your folder under the 

name "entertainment_Zaslavl.shp". Symbolize the layer with red circle. Use CRS 

WGS 84 / UTM zone 35N EPSG: 32635, and "File encoding" – UTF 8. Add the 

created shapefile to your project (click Apply and OK).  

Remove (or uncheck) the “entertainment_Mo” layer from the project (right-click 

the layer name Remove Layer/Group, or – ctrl + D (  icon).  

Step 18. Start editing the “entertainment_Zaslavl” layer. As a source of 

information about tourist attractions in the city of Zaslavl, use the map of Zaslavl.bmp, 

Zaslavl_turistik_map.jpg and Internet resources. Adjust the location of existing 

features using the Vertex Tool – Current Layer (  icon) in the Digitizing Toolbar 

panel. To create new objects when necessary, use the Add Point Feature (  icon) of 

the same panel. When creating the latter, assign a number to each object, fill in the 

name and tourism field (museums or viewpoints). Symbolize the 

entertainment_Zaslavl layer with Categorized (  icon) value, click Classify. Click 

Apply and OK, fig. 103. After all objects have been digitized, save your changes to the 

layer and finish editing. 

 

 

 

Figure 103. – Categorizing the entertainment_Zaslavl layer 
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Another way to show points of interest is to add viewpoint.shp and museum.shp 

as separate layers to the project. 

Step 19. Placing text annotations. The Text Annotation tool provides the ability 

to place formatted text in a callout on a QGIS map. Choose a tool  Text Annotation 

(Attributes toolbar) and click the feature to label. Mouse pointer becomes . Overlay 

it over the red star or other point of interest your mouse pointer and right-click. You 

will see Edit  icon and click it and the Annotation Text dialog box with various 

options will pop up, fig. 104. The frame appears with white background on default. 

Click the "Frame style" and select, e.g. light-yellow background color. Type the 

required text, edit its font, style and size. Do same with the frame size, its position and 

other parameters of the created annotation. Click once more the icon  Text 

Annotation (Attributes toolbar), the Text Annotation panel disappears. 

 

 
 

Figure 104. – The Annotation text panel 

 

Underwrite with the help of annotations a few more objects adjust other 

parameters when necessary and click OK. Finally put again the mouse pointer inside 

the frame on your map with white background on default, catch the upper side of the 

frame and adjust its size to required dimensions and move its frame to desired position. 

The text annotations were added. You can create other text annotation yourself. The 

final view of the map is shown in fig. 105. 
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Figure 105. – View of the map with annotations 

 

II. Creating actions in QGIS 

Actions in QGIS allow you to add a number of extras to the map functions. For 

example, you can create actions to display image, organize a web search or generate a 

report from a database by value.  

Step 1. Using Internet resources, find a few photographs of tourist sites in the 

town of Zaslavl and save them to a working folder with the *.jpg extension (for 

instance: Zaslavl_1.jpg, Zaslavl_2.jpg, Zaslavl_3.jpg). 

Step 2. Open the attribute table of the “entertainment_ Zaslavl” layer. Turn on 

layer edit mode (Toggle Editing Mode). Click on the New Field ( icon). In the Add 

field window, specify Name - hot_link, Type – Text (string), Length – 60, fig. 106. Fill 

in the hot_link field for individual tourist objects, writing down the full path to the 

corresponding image file (fig. 107). Save your changes. Exit edit mode. 

 

 
 

Figure 106. – Add Field panel 
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Figure 107. – Enertainment_Zaslavl – Features Total panel 

 

Step 3. Right click on the layer name "enertainment_Zaslavl" in the legend and 

open the layer Properties window. Select the Actions tab. To create a new action, click 

on the  Add a new action button. In the drop-down “Action List” from of the dialog 

box that opens, select the Generic one, in the Description line type open_image. In the 

action window, type cmd /c. Choose those hot_link field in the dropdown list 

containing field names layer "entertainment_Zaslavl.shp" and click Insert. Now your 

text action looks like this: cmd /c[%"hot_link"%], fig. 108. Add action to the list for 

this layer by clicking OK. Action created. On the Actions tab of the Layer Properties 

dialog box, click Apply and OK. 

 

 
 

108. – Layer properties and actions 

 



76  

Step 4. Zoom in on the area of interest in the map window using the  Zoom 

in tool. On the attribute panel, activate the  Actions tool and click on the symbol of 

the corresponding tourist object in the map window, fig. 109. 

 

 

 
  

Figure 109. – Adding a photo 

 

III. Create a map layout 

QGIS uses a map builder to create map layouts. The latter allows you to add the 

following elements: QGIS map, legend, scale bar, images, shapes, arrows, and text 

boxes. When creating a layout, you can resize, group, align, and change the position of 

each element, as well as setting their properties. The finished image can be printed or 

exported to a bitmap. In addition, the layout can be saved as a template and reused in 

another session. 

Step 1. Before you start working on the map layout, make sure that the vector 

layers look the way you want them to. Turn off the visibility of the raster, delete the 

"railway_Mo" and "entertainment_Mo" vector layers. Open the map builder dialog 

(Project → New Print Layout) or click the  icon. Name the new layout 

"Touristic_map". Click OK, fig. 110. 

The layout editor window can be conditionally divided into the following areas: 

1) menu bar, 2) toolbars, 3) display window of a “sheet of paper”, 4) floating windows 

(panels), 5) status bar, fig. 111. 
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Figure 110. – Create Print Layout 
 

 
 

Figure 111. – Print Layout panel 
 

Floating panels include the following tabs: Layout, Items, Item Properties. On 

the Layout tab, you can set change the paper size and orientation, set the print quality 

in dpi and activate check snapping to the grid with a given step, Project, Global Layout 

variables and others, fig. 112.  
 

 
 

Figure 112. – Layout tab 
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The Item Properties tab is used to display and edit properties of the selected 

element.  

The Items – History panel displays a history of all changes made to the layout. 

Here you can both undo the changes made and redo previously undone actions. 

Step 2. To add a QGIS map to the layout, click the button  Add Map to the 

layout toolbar and draw a rectangle on the layout sheet. The added map can be 

displayed in one of three modes, which can be selected on the Item Properties tab when 

the map is selected: 

● rectangle. An empty rectangle with text is displayed "Map"; 

● cache. Draws the map at the current screen resolution; 

● rendering. Selecting this mode means that when zooming in the Composer 

window, the map will be redrawn, but only up to the maximum resolution to save 

space. 

On the Item Properties tab, you can adjust the image scale and other elements. 

You can resize the map, do other corrections, fig. 113, and moving one of the blue 

markers in the corners. To move layers within a map, select it, then click the button 

 Interactively Edit Map Extent and move the layers inside the object by holding 

down the left mouse button. 

 

 
 

Figure 113. – Fragment of the Item Properties tab 
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Step 3. Add a legend to the map layout by clicking the button  Add Legend, 

move the mouse to the desired location layout, and by pressing and holding the left 

mouse button, drag cursor by drawing a rectangle, names of layers appear. With the 

legend selected in the window Layout Item Properties, change the "Title" to "Legend". 

Disable the Auto Update option. In the list of Legend Item Properties, change the name 

"entertainment_Zaslavl" (double click on this element) to "Tourist objects", "museum" 

to museums, "view point" to monuments of culture and architecture. Remove from list 

other layers with the selected element, click  Delete (fig. 114). 

 

 
 

 
 

Figure 114. – Creating the Legend at the Item Properties tab 
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Step 4. Add a scale bar to the map layout using (Layout → Touristic Map → 

Add Scale Bar) and draw a rectangle, where Scale Bar appears. Using the Scale bar 

(Item Properties) dialog, set: "Segments" left – 0, "Segments" right – 4. Select the 

"Scalebar Units" – kilometers and "Label for units" – km. Check the radio button for 

Fit Segment Width. Other options are in fig. 115. 

 

 
 

Figure 115. – Formatting the Scalebar at the Item Properties tab 

 

Step 5: Use the  Add Picture tool to add the photos used to create the activity 

to the layout. Check the radio button "Raster image". The path to the image is written 

when the image is selected in the Item Properties window, Image source field. 

Step 6: Select all the images and group them by clicking on the  Group items 

icon. 

Step 7. To add a title, click the  Add Label button, place the cursor at the top 

of the map, and then, holding down the mouse button, drag out a rectangular frame. In 

the frame with default text "loren lpsum" of Main Properties dialog box of the "Label" 

group, in the Appearance subsection, set the Font to Times New Roman, the Style to 

bold, and its size to 24. As the title of the map, enter "Tourist map of the town of 

Zaslavl". Edit the size of the text window and its position on the map, fig. 116. 
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Figure 116. – Tourist map of Zaslavl town 

 

Step 8. Export the created layout (Project – Import/Export – Export Map to 

Image) to a bitmap image for subsequent cartographic printing. In the panel "Save Map 

as Image" that appears click Save with the name "Tourist map.jpg" in your folder. 

 

2.5. Laboratory work 5. Receiving basic spatial characteristics of objects 

in QGIS 

 

The purpose of the laboratory work: to learn an algorithm for obtaining the 

main spatial characteristics of objects in QGIS. 

 

Initial data: 

● shapefile containing borders of Belarusian regions (regions_ RB.shp); 

● shapefiles containing the river network (rivers_RB.shp) and lakes of the 

Republic of Belarus (lakes_RB.shp); 

● shapefile of cities in the Republic of Belarus (towns_RB.shp). 

 

Laboratory progress 

 

Like most modern GIS, QGIS makes it possible to automatically calculate 

spatial characteristics (coordinates, areas, perimeters, etc.) for objects in vector layers. 

At the moment, QGIS implements the following tools for calculating spatial 

characteristics: 

● tool Vector → Geometry Tools) permits to add field(s) to the layer with 

geometry information: xcoord, ycoord for a point layer, length for a line layer, area, 

perimeter for a polygon layer. Supports three ways of calculating spatial 

characteristics: 1) in the layer coordinate system; 2) in the project coordinate system; 
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3) on an ellipsoid. When calculating on an ellipsoid, point coordinates are returned by 

default in decimal degrees, and lengths and areas are returned in meters, regardless of 

the view or layer coordinate system. You can specify the Ellipsoid for calculations on 

the General tab of the Project Properties dialog box. By default, this is the WGS 84 

universal ellipsoid; 

● a set of functions for calculating spatial characteristics in the field calculator. 

Step 1. Open QGIS Desktop 3.34.6. Add the following vector layers to the 

project, located in the source data folder: regions_RB.shp, lakes_RB.shp, 

towns_RB.shp (Layer → Add layer → Add vector layer). Place the layers in the project 

in the following order from top to bottom: rivers_RB, towns_RB, lakes_RB, 

regions_RB. These layers will be shown in random colors. 

Step 2 Define the coordinate system of the rivers_RB.shp shapefile. To do this, 

right-click the specified layer in the Layers window and select Properties from the 

context menu. On the Source tab of the Layer Properties dialog box, in the Assigned 

Coordinate Reference System (CRS) section, information on the shapefile's coordinate 

system will be displayed. The coordinate system of the layer is the projection 32635 

WGS 84 / UTM zone 35N, the units of measurement are meters, fig. 117. 

 

 
 

Figure 117. – Layer properties – rivers | Source panel 
 

Step 3. Calculate the areas and perimeters of lakes, for which in the menu Vector, 

go to Geometry Tool → Add Geometry Attributes..., fig.118. 
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Figure 118. – Work with geometry tools 
 

In the dialog box that opens, Specify "lakes_RB" as the Input layer. In the field 

Calculate using set Layer CRS. The Added geom info field is set to [Create temporary 

layer] by default, leave it as is (the temporary layer will be deleted after finishing the 

session with QGIS). Click the Advanced options (  icon) and select in the Invalid 

feature filtering window change Use Default for Do not Filter (Better performance), 

fig. 119. Let's leave the rest set by default. Click Run, fig. 120 

 

 
 

Figure 119. – Advanced options panel 

 

 
 

Figure 120. – Work with geometry tools 
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After the features are computed, the "Added geom info" layer will be added to 

the project. Check the result. Open the layer's attribute table (right-click on the layer 

name in the table of contents → Open attribute table) and click it, fig. 121. There are 

two new columns "area" and "perimeter", fig 122. 

 

 
 

Figure 121. – Add geometry info panel 

 

 
 

Figure 122. – Added geom info panel 

 

Step 4. Obtaining main statistical indicators for the "area" field. From the Vector 

menu, choose Analysis Tools → Basic Statistics for Fields…, click it, fig. 123.  

 

 
 

Figure 123. – Basic statistics for fields 
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In the dialog box, for Input Layer select Added geom info. In the drop-down list 

of "Field to calculate statistics on", select the "area". Leave the default value in the 

field Statistic [optional] field, fig. 124. Click Run. The calculated indicators (minimum 

value, maximum value, range, sum, mean value, median, standard deviation, etc.) will 

be displayed in the Log window, fig. 125. The list can be copied to clipboard when 

necessary. 

 

 
 

Figure 124. – Basic statistics for fields 

 

 
 

Figure 125. – Basic statistics for lakes in Belarus 
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Step 5. Calculate the total length of rivers within the regions of Belarus. As for 

the “area” statistics from the Vector menu, choose Analysis Tools → Sum Line 

Lenghs… and click it, fig. 126. The Sum Line Length dialog panel pops up the polygon 

is regions_RB, the original vector layer is rivers_RB. Next line (Lines length field 

name) specify "LENGTH" – a field with information about the length of a linear 

objects. In the Lines count field name field, type COUNT. Save the result as a file to 

your folder called "rivers_length.shp", fig. 127.  

 

 
 

Figure 126. – Selecting Line Length panel 

 

Go to the menu Vector → Analysis Tools and you take Sum Line Lengths... and 

click it, fig. 126. The Sum Line Length dialog panel pops up. As the original Lines layer 

select "rivers_length", for Polygon – "regions_RB". Next line (Lines length field name) 

specify "LENGTH" – a field with information about the length of a linear object. In 

the Lines count field name field, type COUNT. Click the Advanced options (  icon) 

and select in the "Invalid feature filtering" window change Use Default for Do not 

Filter (Better performance), see fig. 105. Save the result as a file to your folder called 

"regions_riv.shp", fig. 127. Click Run. 

 

 
 

Figure 127. – Sum Line Lengths panel 
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The Attribute table for river lengths with added rows LENGTH and COUNT 

is show in fig. 128. 

 

 
 

Figure 128. – Table of attributes for rivers divided into 5 regions 

 

After the algorithm is executed, the "Line length" layer will be added to the 

project, rename it to "river lengths". Symbolize the layer with a Graduated ( icon) 

over the LENGTH field. Number of classes – 3. Mode – Equal Count (Quantile), fig. 

129. Click Apply and OK, The territory of Belarus, indicating into 3 classes, lengths of 

rivers is shown in fig. 130. 
 

 
 

Figure 129. – Symbolizing river lengths 
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Figure 130. – Symbolizing river lengths for Belarus 

 

Step 6 Convert the "towns_RB" polygon layer to a point layer. To do this, in the 

Vector menu, select Geometry Tools → Centroids, fig. 131. The Input layer is 

"towns_RB". Save the centroids as a temporary layer, click Run, fig. 132. Open the 

output Centroids layer added to the Layers panel after executing the algorithm, fig. 

133. 

 
 

Figure 131. – Creating centroids for towns_RB 

 



89  

 
 

Figure 132. – Creating centroids for towns_RB 
 

 
 

Figure 133. – Centroids of polygons towns_RB 
 

Step 7. Calculate coordinates of the cities in the layer's coordinate system. From 

the Vector menu, select Geometry Tools / Add Geometry Attributes, fig. 134. Set the 

Source Layer to Added geom info. Save results the file "Centroids_XY", fig. 135. 

Results with determined coordinates for centroids shown in fig. 136. 
 

 
 

Figure 134. – Starting to determine coordinates for centroids of towns_RBx 
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Figure 135. – Starting to determine coordinates for centroids of towns_RBx 

 

 
 

Figure 136. – Coordinates x and y determined for centroids of towns_RBx 

 

Step 8. Calculate the coordinates of the cities in the Project coordinate system. 

First, set the geographic coordinate system for the project to WGS 84. From the 

Projects menu, select Project Properties, fig. 137. 

 

 
 

Figure 137. – Project – Properties menu 
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Switch to the CRS tab in the Project Properties panel. Set the project coordinate 

system to WGS 84 / UTM zone 35N. Click Apply and OK. 

Like in the Step 7, calculate coordinates of the cities in the Project's coordinate 

system. From the Vector menu, select Geometry Tools / Add Geometry Attributes, see 

fig. 134. Set the Source Layer to Added geom info. Save results the file 

"towns_XY.shp". 

Open the attribute table of the shapefile "towns_XY" (right-click on the layer 

name in the table of contents → Open attribute table). The attribute table contains two 

sets of coordinates calculated in the layer coordinate system and the project coordinate 

system, fig. 138. 

 
 

Figure 138. – Attribute table for towns 

 

Step 9. Using the field calculator. The attribute table field calculator allows you 

performing calculations based on existing attribute values or predefined functions.  

 

Table 2. Field calculator functions for obtaining spatial characteristics 

 

 

Function  
Geomet 

type 
Description  

$x  Point  Returns the X-coordinate (longitude) of a 

point 

$y  Point Returns the Y (latitude) coordinate of a 

point 

$length  Line Returns the line length 

xat  Line  Returns the X-coordinate (longitude) of the 

nth point of the line (index starts at 0; 

negative values are counted from the last 

index value) 

yat  Line Returns the Y coordinate (longitude) of the 

nth point of the line (index starts at 0; 

negative values are counted from the last 

index value) 

$perimeter  Polygon  Returns the perimeter of a polygon 

$area  Polygon  Returns the area of a polygon 
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The Geometry Tools group combines functions for working with object 

geometry. Among them are functions that allow you to get the length of the line, the 

perimeter, the area of the polygon, etc. (Table 2). When calculating spatial 

characteristics using the field calculator, all calculations are made in layer units. 

Calculate the areas of features in the polygon layer "regions_RB" (the layer with 

the administrative boundaries of the regions) using the field calculator. To do this, open 

the attribute table of the layer. Put the layer in edit mode  Toggle editing mode (Ctrl 

+ E), fig. 139.  
 

 
 

Figure 139. – Entering the editing mode for "regions_RB" – Open Attribute table 

 

Launch the field calculator by clicking on the icon  Open Field Calculator. 

In the Field Calculator dialog box that opens, check the box next to Create a new field. 

Give the field a name, such as "area". Output Field type – decimal number (real), 

Output Field Length – 15. By setting the size, we specify the total number of characters 

before and after the decimal point, and by specifying the precision – the number of 

decimal places. Next, select the required calculation function from the list. All 

functions for calculating the spatial characteristics of objects are in the "Geometry" 

group. You can add a function to the command line either by writing it manually or by 

double-clicking on the selected function from the list. After all manipulations, the 

window should look like in fig. 140. 
 

 
 

Figure 140. – Field calculator panel 
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Click OK and check the Attribute table. The new field "area" displays the 

calculation results. The area is indicated in square meters. 

Calculation of spatial characteristics of point, line and polygonal objects using 

the field calculator is carried out according to a single algorithm: 1) creation and 

determination of field parameters for calculations; 2) application of one of the 

calculated functions. 

 

2.6. Laboratory work 6. Joining tables in QGIS 

 

The purpose of the laboratory work: to learn the algorithm for joining tables 

by a common field and spatial join in QGIS; creation of charts. 

Initial data: 

● shapefile containing the administrative border of Belarus (RB.shp); 

● shapefile containing the boundaries of the regions of Belarus (regions_rb.shp); 

● shapefile of settlements in Belarus (settlement.shp); 

● data on emissions of pollutants (thousand tons) into the atmosphere from 

stationary sources for individual cities of Belarus from 2012 to 2016 and on the 

structure of emissions of pollutants from stationary sources by regions for 2013 

(pollution) in MS Excel format; 

● shape file containing the border of the Brest region (Brest_region.shp); 

● shape file containing the boundaries of administrative regions Brest region 

(Brest_district.shp); 

● shape file of sights (points of interest) (POI) of the Brest region 

(poi_point.shp). 

 

Laboratory progress 

 

I. Joining tables by common field 

As a result of joining tables, data from one table is added (joined) to another, i.e., 

the result of the operation is a new (modified) table containing fields from two joined 

tables. The connection is made by a field that exists in both tables. A communication 

is carried out according to the principle "one to one or many to one (records)". The 

field name does not have to be the same in both tables, but the data type must be the 

same. You can join integers with integers, strings with strings, and so on. 

Step 1. Open QGIS Desktop 3.34.6. Create a new project. Using the Layer → 

Add Vector Layer  tool, load the placed in the folder with the source data, shapefiles: 

regions_RB, RB, settlement. Symbolize the "RB" layer as follows (click right-click on 

this layer in the Layers window → Properties → Symbology): Single Symbol ( ) – 

Symbol layer type – Simple line; Fill color – no fill; Fill style – Solid; Stroke color – 

Red, Stroke width – 0.6, fig. 141.  
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Figure 141. – Symbology panel for RB 

 

Render the "regions_RB" layer using the Categorized method. In the Color ramp 

window, enter YlOrBr, fig 142.  

 

 
 

Figure 142. – Symbology panel for regions_RB 

 

Step 2. In the "settlement" layer, select the settlements that have the status of a 

town. Click the icon menu, then Select features by expression... and click it, fig. 

143. The Querry Builder dialog box pops up.  
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Figure 143. – Starting the Querry Builder 

 

In the middle window expand items: Fields and values, Map layers and 

Operators, fig. 144. In the Fields and values list double-click in the PLACE field, it 

appears in the left window Expression, then double click the “=” in the Operators list; 

again highlight the PLACE field and in popped up window click All Unique button, 

select city in its window and double click it, then double click in the Operators list the 

logical operator “OR”; again click sequentially “PLACE”, “=” and “town”. The 

resulting logical expression is shown in fig. 144.  

 

 
 

Figure 144. – Selection by expression panel 

 

Finally expand the Select Features button and click there Add to current 

selection. As a result, settlements with the city status will be highlighted in the 
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"settlement" layer together with other settlements. Close the Select by expression 

dialog panel. 

Step 3. To save your selection as a shape file, right-click settlements → Export 

→ Save Selected Features as…, fig. 145. In the panel which pops up type towns.shp 

together with the path to your working folder, fig. 146. The new layer towns.shp will 

be added to your project. Now you may delete or uncheck the settlements layer, in 

result your canvas image will look like in fig. 147. 

 

 
 

Figure 145. – Saving the selected features 

 

 
 

Figure 146. – Saving vector layer panel 
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Figure 147. – Resulting image with selected towns 

 

Step 4. Open the "pollution" Microsoft Excel document located in the source 

data folder. The file contains information on emissions of pollutants (thousand tons) 

into the atmosphere from stationary sources for individual towns. The document has a 

"name" column, which will be used as a key when creating a connection. Save the 

Microsoft Excel sheet "pollution1" as a text file with the extension *.csv (comma 

delimited). 

Step 5 Using the  Add Delimited text Layer… tool in the Layer → Add Layer 

panel, add the pollution.csv file to the project, fig. 148. In the "Data Source Manager | 

Delimited Text" dialog box, activate in the File Formal – Semicolon. In the Geometry 

Definition group activate “X field” and “Y field” as shown in fig. 149. Click Add and 

OK. The pollution1 table will appear in the layers window. 

 

 
 

Figure 148. – Creating a layer from text file 
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Figure 149. – Creating a layer from text file 

 

Step 6. Add the "pollution1" table (having pollution data with one digit after the 

decimal point) to the project, to the attribute table of the "towns" layer. Click right 

button on the layer name "towns" and select Properties. In the Layer Properties dialog 

box, click the Joins tab. Click the  Add New Join button. In the dialog box that 

opens, in the field Join layer select pollution1, for Join Field select – "name", Target 

field – NAME_EN. Check Cache join layer in memory. Enable the Custom field name 

prefix option and remove the default prefix (Polution). The Join fields to option allows 

you to select which fields from the join table will be added to the target table. Check 

all fields to be added, fig. 150. Click OK. 

 

 
 

Figure 150. – Open Joins panel 
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Once created, the joined list will be shown on the Joins tab. The tool  allows 

you to edit the parameters of an existing connection. A connection can be deleted by 

selecting it in the window and clicking the delete connection button . 

Open the attribute table of the "towns" layer and check if these two tables have 

been joined. 

Step 7. Using the attached data, construct diagrams that reflect the dynamics of 

pollutant emissions into the atmosphere from stationary sources for individual towns. 

QGIS supports the creation of the following types of charts: pie charts, text diagram, 

histogram and stack bars. Charts are overlaid on an existing vector layer. Open the 

properties of the "towns" layer (right-click on the layer name in the legend → 

Properties). Click the Diagrams window. Select Histogram (  icon) from the drop-

down list at the top of the panel. In the Attributes sector, using the Ctrl button, select 

the added fields pollution1_y_2008, pollution1_y_2009, pollution1_y_2010, 

pollution1_y_2011, pollution1_y_2012 and pollution1_y_2013, click . These 

fields, fig. 151, will be used to create the histogram. 

 

 
 

Figure 151. – Layer properties - towns | Diagrams panel 

 

The custom color in rounded squares for the assigned attributes section can be 

changed for each of added items sequentially by double clicking on each of squares, 

the color scale is activated and you’ll be able to select the desired color. Repeat this 

operation for each of rounded squares. The color scale will be added to the "towns" 

layer as well, fig. 152. 
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Figure 152. – Towns layer with pollution data 

 

Click the Rendering tab at this panel. Drag the slider to set the transparency to 

30%. Set the column width to 2.5, fig. 153. 

 

 
 

Figure 153. – Layer properties – towns – Diagrams | Rendering 

 

Click here the Size tab. In the Size units list, select Millimeters. Enter 

pollution1_y_2012 in the Attribute field. Opposite the Maximum value, click Find. Set 

the Bar length to 15, fig. 154. 
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Figure 154. – Layer properties – towns – Diagrams | Size 
 

Click Apply, to display the chart in the map area, and OK, fig. 155. 
 

 
 

Figure 155. – Pollution histograms 
 

Step 8. Create Pie Charts. Save as a text file Pollution2a.xlsx with the .csv 

extension (comma delimited) located in the source data folder. The latter one contains 

information on the structure of pollutant emissions from stationary sources by regions 

as for 2013. 

Load the text file Pollution2a.csv located in the source data folder into the 

project as a table (Add Delimited text Layer… tool in the Layer → Add Layer panel, 

add the pollution2.csv file to the project, fig. 156. In the Data Source Manager | 

Delimited Text dialog box, activate in the File Formal – Semicolon. In the Geometry 

Definition group activate “X field” and “Y field” as shown in fig. 156, click Add and 
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OK). The pollution1 table will appear in the layers window. Please note, leave as is the 

names of regions. 
 

 
 

Figure 156. – Adding the pollution table to the project 
 

Attach the "Pollution2a" table to the "regions_RB" layer. Click right button on 

the layer name "regions_RB" and select Properties. In the Layer Properties dialog box, 

click the Joins tab. Click the  Add New Join button. In the dialog box that opens in 

the field Join layer select pollution2a, for Join Field select – "Region", Target field – 

ID, click OK. Check Cache join layer in memory. The Join fields to option allows you 

to select which fields from the join table will be added to the target table. Check all 

fields to be added, fig. 157. Click OK. The table pollution2a will be shown in the 

Layers panel. 

 

 
 

Figure 157. – Add vector join panel 
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Once created, the joined list will be shown in the Joins tab. The tool  allows 

you to edit parameters of the existing connection. A connection can be deleted by 

selecting it in the window and clicking the  (Delete connection) button. 

Right-click the pollution2a → Open Attribute Table in the "Layers" panel and 

you’ll see its content, fig. 158. 

 

 
 

Figure 158. – Pollution2a table content 

 

On the Diagrams tab of the Layer Properties dialog box, select the chart type – 

Pie Chart (  icon). To create charts, use the attribute fields: Solids, Sulfur dioxide, 

Carbon monoxide, Nitrogen oxides, NMVOCs, Hydrocarbons, others. You can 

change the color for each of rounded squares double clicking on it and selecting the 

required one instead of the custom color. An example of selected set for attributes, is 

shown in fig. 159. 

 

 
 

Figure 159. – Adding attributes for Pie Chart panel 

 



104  

The pollution2a subdivided into specified colors for each of included 

pollutants will be added to the regions_RB at the layers panel and circles of 

different sizes will be drawn within regions of the country, fig 160. 
 

 
 

Figure 160. – Layers panel with added pollution2a 
 

Position the charts inside the polygons (Placement tab). 

On the Size tab, scale you can change the diameter of charts depending on the 

total amount of emissions (“total” field). By clicking on the Find button, set the 

maximum value. Specify the size equal to 30, fig. 161. Click Apply and OK. 
 

 
 

Figure 161. – Selecting parameters of Pie Charts 
 

After finishing with pie charts, you may right-click "regions_RB" → Open 

Attribute Table and the final table looks like in fig. 162. 
 

 
 

Figure 162. – Parameters of Attribute Table for pie diagrams 
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Step 9: Create a chart legend. There is no standard way to get legends for charts 

in QGIS. Let's use the following approach. Open Project → New Print Layout. In the 

dialog box that opens, fig. 163, type the file name (e.g. "Test6_Layout") and click OK. 

The Test6_Layout panel opens, it’ll be used to create the pollution map, legend (kinds 

of pollutants), attribute table and corresponding labels. Click Add Map (  icon), then 

with mouse left button draw the square area and release it. An image of the pollution 

map will appear within the indicated square, its size and position could be adjusted to 

the desired extent, fig. 164. Click at any empty location and the bounding square 

disappears. 

 

 
 

Figure 163. – Starting to create print layout 

 

 
 

Figure 164. – Adding the pollution map to the layout 

 

In a similar way add the legend (kinds of pollutants), click the Add Legend 

 icon, create a bounding rectangle with the left mouse button and release it, the 

legend will be added. Then click Add Attribute Table  icon and in a similar way 

add this table to the layout and adjust its position. Finally add titles of three added 

images, click the  icon, create the frame and instead of default ("Lorem Ipsum"), 

fig. 165, type "Pollutions within individual regions", adjust its position and font size. 
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Figure 165. – Adding labels 

 

In similar way create labels "Kinds of pollutants" and "Attribute table" 

labels. Finally, your layout looks like shown in fig. 166. 

 

 
 

Figure 166. – A layout of pollutions within regions of Belarus 

 

II. Spatial Data Connection 

A spatial join is similar to an attribute join, i.e., as a result of the join, attributes 

from one layer are attached to attributes of another related record; however, it is based 

on a spatial relationship between the objects in these two themes. 
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Step 1. Create a new project (Projects → New). Add shapefiles to the project: 

poi_point, Brest_region, Brest_district (located in the source data folder). Symbolize 

the "Brest_region" layer with a Single Symbol (  icon), Fill style – no fill, Symbol 

layer type – Simple line, Stroke style – Solid line, Stroke width – 1.0, Color – red. 

To display the "Brest_district" layer, use the legend type Categorized (  icon) 

by Value NAME. Click Classify button. Choose colors of your choice. 

Step 2. Select the objects of the "poi_point" layer located on the territory of the 

Brest region. To perform a selection based on spatial position, clip the poi_point layer 

within the Brest region area, save results as Brest_poi_point (fig. 167) with Data 

source encoding UTF-8 and CRS – 32635 – WGS 84 / UTM zone 35N. The clipped 

area looks like in fig. 168. Now you may deactivate or remove the “poi_point” layer 

from the project. 

 

 
 

Figure 167. – Clipping points of interest for Brest region 

 

 
 

Figure 168. – Brest region classified with poi_points 

 

Step 3. Create a point feature layer containing information about the region's 

petrol stations. With the Brest_poi_point layer selected open Attribute table and in the 

appeared panel Brest_poi_point – Select Features, click the Select features using an 

expression (  icon). In the Brest_poi_point – Select by Expression dialog, write the 
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expression AMENITY = 'fuel' (fig. 169). Click Select Features button. Close the 

window. 
 

 
 

Figure 169. – Selecting fuel filling points within Brest region 
 

The results with the selected features are in the memory. There is no an option 

to save them as a file in the panel, fig. 169. To do this you need to save your selection 

into a new vector layer file. To save it, firstly copy them click at the toolbar Edit menu 

Copy Features, then click Edit → Paste Features As → New Vector Layer in the 

desired format. Save the selected objects to a separate file "Brest_fuel_point.shp". Add 

the created shapefile to the project, fig 170. 
 

 
 

Figure 170. – Saving the file with fuel filling points within Brest region 
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Step 4. Spatially connect the point layer "Brest_fuel_point" and the polygon 

"Brest_district". From the Vector menu, select Data Management Tools → Merge 

Vector Layers, fig. 171. 
 

 
 

Figure 171. – Merging vector layers 
 

In the Merge vector Layers dialog box, specify "Brest_district" as the target 

feature layer, and "Brest_fuel_point" as the target layer to merge. Enable the Open 

output file after running algorithm option, fig. 172. Click Run. 

The fuel points within districts of the Brest region as shown in fig. 173. 
 

 
 

Figure 172. – Merging attributes for districts 
 

 
 

Figure 173. – Merging vector layers 
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2.7. Laboratory work 7. Search the shortest route with road graph for 

QGIS 

 

The purpose of the laboratory work: to learn the algorithm for finding the 

shortest route between two points of a linear vector layer using the Road graph. 

Initial data: 

● shapefile containing the boundary of the city of Polotsk (boundary.shp);  

● shapefile of roads in Polotsk (roads.shp). 

 

Laboratory progress 

The Road graph extension is designed to find the shortest distance on a road 

graph. Any line vector layer in a format supported by QGIS can be used as a road layer. 

The main features of the module: calculation of the route, its length and travel time; 

optimization by criterion of distance or time; route export to a vector layer. 

Step 1. Open QGIS Desktop 3.34.6. Create a new project and use the  Add 

Vector Layer tool to add the "roads" and "boundary" shapefiles located in the source 

data folder to the project. Symbolize the "boundary" layer with a Single Symbol (  

icon). The Fill style is No Brush. Symbol layer type – Simple Fill, Stroke color – on 

your choice (e.g.) burgundy, Stroke width – 0.8 mm. Transparency – 20 %. Draw the 

"roads" layer with a solid line in dark brown, fig. 174. 

 

 
 

Figure 174. – Calculator for fields panel 

 

Step 2. Activate the Shortest Path: Processing → Toolbars → Network analysis 

→ Shortest path (point to point). It includes the following items: Vector Layer 

Representing Network, Path Type to Calculate (Shortest/Fastest), Start Point, End 

Point, Advanced Parameters. You can open and learn it. 
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Step 3. Examine the attribute information of the “roads” layer (right-click on the 

layer name in the legend area → Open Attribute Table). The HIGHWAY field contains 

information about road types in terms of their importance in the road network. So, 

primary are the central thoroughfares of the city, secondary (track) are the main 

thoroughfares of the city districts, tertiary are the main streets in relation to other small 

streets / alleys, unclassified are small streets / alleys, mainly with non-residential 

buildings along the street, residential and living_street are small streets / alleys, 

mainly with residential buildings along the street, service – service driveways, 

pedestrian – pedestrian streets, cycleway – paths for cyclists, footway – sidewalks, 

paths, track – field and forest roads. 

Let's fill in the MAXSPEED field, which contains information about the 

permissible speed on the section of movement. 

Switch to edit mode. With the "roads" layer selected in the legend window, right-

click on the tool  Toggle edit mode. On the toolbar, select  Open field calculator. 

In the window that opens, check the Create a new field option, specify the Field name 

– maxspeed1, Type – an integer. In the Functions (middle) window, expand the Fields 

and Values list and double-click MAXSPEED. Click OK. A new numeric field with 

the copied values of the MAXSPEED attribute will be created, fig. 175. 

 

 
 

Figure 175. – Calculator for fields panel 

 

Step 4. In the Attribute Table for "roads" click Toggle editing mode, then click 

 icon Select objects that meet the condition button. In the Select features using an 

expression dialog box that opens, do the following: txpand the Fields and Values list 

and double-click HIGHWAY, then double-click the "=" operator. Select ‘primary’ from 

the list that appears. Click the Select Features button, fig. 176. Close the panel. 
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Figure 176. – Select by expression – roads panel 

 

In the attribute table, we will display only selected objects. To do this, in the 

lower left part of the Attribute Table window, select Show Selected Features from the 

drop-down list, fig. 177. 

 

 
 

Figure 177. – Road parameters assigning 

 

For most of the selected objects, the maximum speed is already set (maxspeed1 

field). For selected objects with unspecified speed, replace the NULL value with 60 in 

the maxspeed1 field. 

Similarly, select the main highways of the city districts (HIGHWAY = 'track') 

and for objects with unspecified speed, replace the NULL value with 60 in the 

maxspeed1 field. 

Highlight main streets in relation to other small streets/lanes (HIGHWAY = 

'tertiary'). Use the  Field Calculator to automatically fill in the maxspeed1 field. In 

the dialog box, select the maxspeed1 field from the drop-down list. In the Feature 

window type, for instance, 40. 
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In the Field Calculator, set the maximum speed for the unclassified road type to 

40, service to 20, residential to 20, living street to 20, and primary link to 60. 

Save your changes to the attribute table (  Save Edits) within the Attribute 

Table and exit edit mode. Close the attribute table for the "roads" layer. 

Step 5: Create a filter to display a subset of roads that allow vehicular traffic. To 

do this, in the legend area, right-click on the "road" layer and select Filter from the 

context menu. In the Query Builder panel that opens, perform the following sequence 

of actions: double-click on the field of the HIGHWAY attribute table, then on the 

relational operator "!=" and on the value 'pedestrian'. Next, press the logical AND 

button, select HIGHWAY again, then '!=' and double-click the 'footway' value. 

Similarly, add the 'path' and 'steps' values to the query, fig. 178. After that click OK. 

As a result, the "road" layer will display roads on which traffic is allowed. 
 

 
 

Figure 178. – Query builder panel 
 

Step 6. Extract vertices which could be used as ‘Start Point’ and ‘End Point’ for 

the Shortest Path (Point to Point) module. Open in the Vector menu Geometry Tools – 

Extract Vertices, fig. 179.  
 

 
 

Figure 179 – Selecting Extract Vertices 

 

The extract vertices dialog panel pops up, fig. 180. Open "Roads" for the Input 

layer and your resulting folder in the "Vertices" window, check the "Open output file 

after running algorithm". Click "Run". The layer "RoadVertices" will be added to the 

project. 
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Figure 180. –Extract Vertices panel  

 

Open the Shortest Path: Processing → Toolbars → Network analysis → Shortest 

path (point to point) module. In the dialog panel that pops up it is necessary to enter 

start and end points. Do this in a following way: In the Edit menu → Select → Select 

Feature, then select the start vertices, left click it circle, then right-click it and copy its 

coordinates. Go into already opened Shortest path (Point to point) panel and right-click 

in the Start point window, these coordinates appear within it. Again, return to Edit 

menu → Select → Select Feature, then select the end vertices, left click it, then right-

click it and copy its coordinates. Go into Shortest path (Point to point) panel and right-

click in the End point window, these coordinates appear within it. Other options leave 

as shown in fig. 181. Click "Run", after finishing calculations click "Close". The 

Shortest Path layer will be added to the project. 

 



115  

 
 

Figure 181. –Extract Vertices panel  

 

Highlight it, open its Properties and symbolize it with a "Single Symbol" (  

icon). "Symbol layer type" – Single Line, other parameters shown in fig. 182.  

 

 
 

Figure 182. –Symbolizing the Shortest path panel  

 

You can repeat the algorithm with selected Fastest Path instead of Shortest path 

in the window "Path type to calculate" for preserving other existing parameters and 

saving results in the Fastest path.shp in your working folder. In this case, the both lines 

will coincide. The resulting map looks like in fig. 183. 
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Figure 183. – The shortest path shown in black line 

 

Step 7. To load the OpenStreetMap with the local geographic environment of 

the considered area, open in the Web menu: then QuickMapServices → OSM → OSM 

Standard, fig. 184. Click it, the background image will be added to your map with the 

shortest path in between two selected points (vertices).  

 

 
 

Figure 184. – Loading the OSM Standard to the map 
 

The resulting map with created layers and the position of the Shortest path (point 

to point) module in the QGIS 3.34.6 program package looks like in fig. 185. 

 

 
 

Figure 185. – Map with the shortest path shown in black line 
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2.8. Laboratory work 8. Construction and analysis of a digital relief model 

 

The purpose of the laboratory work: to learn the algorithms for interpolation 

and analysis of hypsometric surfaces implemented in QGIS. 

Initial data: 

● shapefile containing the border of the Vilejka region (Vilejka_district.shp); 

● shapefile containing the elevation data (points_relief.shp). 

 

Laboratory progress 

 

Step 1. Open QGIS Desktop 3.34.6. Load the shapefiles located in the source 

data folder into the new empty project: points_relief as a set of 1.5 mm circles and 

Vilejka_district. Symbolize this polygon layer of the boundary of the study area 

"Vilejka_district" with a Single symbol (  icon). The fill style – no fill. Stroke color – 

red, Stroke width – 0.8 mm, fig. 186. 

 

 
 

Figure 186. – Vilejka region – source data 

 

To fulfill this exercise, we need three QGIS modules. 1) Interpolation module, 

which allows you to interpolate a vector point layer using two methods: triangulation 

(TIN – Triangular Irregular Network), which you can find in the Processing Toolbox 

(Interpolation → TIN Interpolation) and inverse distance weighted (IDW – Inverse 

Distance Weighted), to open it use: Processing Toolbox (Interpolation → IDW 

Interpolation); 2) the Relief module in the Processing Toolbox (Raster terrain analysis 

→  Relief); 3) Raster information module in the Processing Toolbox (GDAL → 

Raster miscellaneous →  Raster information. 
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Step 2. We will create a digital relief model of the Vilejka district of the Minsk 

region by interpolating the values of the heights of reference points. The QGIS 

Interpolation module allows you to interpolate a vector point layer using two methods: 

triangulation (TIN – Triangular Irregular Network), which you can find in the 

Processing Toolbox (Interpolation → TIN Interpolation →) and inverse distance 

weighted (IDW – Inverse Distance Weighted), to open it use: Processing Toolbox 

(Interpolation → IDW Interpolation). 

Step 3. Open the "Processing → Toolbox" (Interpolation → IDW Interpolation). 

In the dialog box that opens, as the input Vector layer, set the points_relief, 

Interpolation attribute – H. Click the Input layer(s) button ( ). Change the "Distance 

coefficient" to 4. In the "Pixel size X" and the "Pixel size Y" resolutions set to 200 

pixels. Click the "Set to current map canvas extent" button, coordinates of four map 

corners will filled in together with the map CRS. Check the "Open output file after 

running algorithm". In the Interpolated window, save the raster to your folder under 

the name "relief.bmp". Leave the rest of the parameters set by default, fig. 187.  

 

 
 

Figure 187. – Dialog panel of the IDW interpolation 

 

After you fill required parameters at the IDW dialogue panel, click Run and 

when calculations will be finished, click Close. A grayscale image will appear on the 

screen, it will look like in Fig. 188. 
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Figure 188. – Grayscale image of elevations within the region 
 

Step 4. Cut the interpolation model on the topic "Vilejka_district". To do this, in 

the Raster menu, select Extraction → Clip Raster by Mask Layer. In the appeared 

dialog box, select "Input layer" – relief. "Mask layer" – Veliejka_district, "Clipping 

mask" relief_IDW.tiff. The raster is saved in the GeoTIFF format. Activate "Match the 

extent of the clipped raster to the extent of the mask layer" and the "Open output file 

after running algorithm", for – "Mask Layer" select Vilejka_district, fig. 189. Click 

OK. Close the Clip Raster by Mask Layer dialog panel. 
 

 
 

Figure 189. – Clipping panel 
 

Turn off the visibility of the "point_relief" layer. 

Step 5. Once loaded, the relief_IDW layer is displayed in grayscale. Open the 

layer properties (right-click on the layer name in the legend → Properties). Click the 
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"Symbology" tab. Change the rendering style in the "Render type" field from 

Singleband gray to Singleband pseudocolor. "Interpolation" is linear. Select an 

appropriate color map in the "Color ramp", for example Turbo. Click the "Classify" 

button. Other parameters are shown in fig. 190. Apply the settings you have made. 

Close the window. 

 

 
 

Figure 190. – Adjusting the IDW pseudocolor 

 

Step 6. Similarly, open the Processing Toolbox (Interpolation → TIN 

Interpolation). In the dialog box that opens set the points_relief as the input Vector 

layer. Interpolation attribute – H. Click the Input layer(s) button ( ). In the "Pixel size 

X" and the "Pixel size Y" set to 200 pixels. Click the "Extent" button. In the 

Interpolated window, save the raster file under the name "relief_TIN.shp". Leave other 

parameters set by default, fig. 191. 



121  

 
 

Figure 191. – Dialog panel of the TIN interpolation 

 

After you fill required parameters at the TIN dialogue panel, click Run and after 

finishing calculations click Close. Save the TIN method under the name "relief_TIN". 

The layers relief1 and relief_TIN will be added to the project, fig. 192. 

 

 
 

Figure 192. – Dialog panel of the TIN interpolation 
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The relief_TIN layer is displayed in grayscale. Symbolize the layer with "Single 

Channel Pseudo Color" style. To do this open the layer properties (right-click on the 

layer name in the legend → Properties). Click the "Symbology" tab. Change the 

rendering style in the "Render type" field from Singleband gray to Singleband 

pseudocolor. "Interpolation" is linear. Select an appropriate color map in the "Color 

ramp", for example Turbo. "Mode" – Equal intervals. Click the "Classify" button. 

Other parameters are shown in fig. 193. Click Apply and OK, after finishing the 

algorithm close the window. 

 

 
 

Figure 193. – Adjusting the TIN pseudocolor 

 

Step 7. Create a hillshade theme (a hillshade bitmap is used to give the image a 

three-dimensional look). In the Processing →Toolbox open the "Relief" module 

(Raster terrain analysis →  Relief). 

In the dialog box that opens, specify relief_IDW as the relief layer. Save the 

Elevation layer to your folder under the name "Hillshade_IDW". Set the Z factor to 2. 

Check the boxes "Open output file after running algorithm" and "Generate relief 

classes automatically", fig. 194. Click OK. The Hillshade_IDW layer will be added to 

the project. 
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Figure 194. – Hillshaded view for relief_IDW 

 

Step 8 Combine the light-shadow hillshading and a digital elevation model 

(DEM). To do this, turn off the visibility of the "relief_IDW" layer. In the legend, place 

the "Hillshade_IDW" layer below the "relief_IDW" layer. Open the properties of the 

"relief_IDW" layer (right-click on the layer name in the table of contents → 

Properties). Go to the Transparency tab. By dragging the slider, set the optimal overall 

transparency of the layer, fig. 195.  

 

 
 

Figure 195. – Adjusting the overall transparency for relief_IDW 

 

Step 9 Similarly produce the Hillshade_TIN layer based on "relief1" layer. The 

dialog panel and Hillshaded view for "relief1" are in fig. 196. In this case, set the Z 

factor to 12, fig. 196. Save the layer to your folder under the name "Hillshade_TIN". 

Combine the "relief1" digital model and the appropriate hillshade. 
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Figure 196. – The Relief_TIN panel (left) and Hillshade_TIN (right) 

 

Results, received using both models IDW and TIN shown in fig. 197. Select the 

model that, in your opinion, most accurately reflects the real hypsometry of the study 

area, rename it in the project to "Digital Elevation Model" (Layer properties → Source 

→ Layer name). Delete or disable the second model and its corresponding shadow 

wash. 

 

  
 

Figure 197. – Comparing versions for models IDW (left) and TIN (right) 

 

Step 10 Open properties of the DEM layer. Click the Histogram tab to view the 

distribution of height values in the study area, fig. 198. Click on the Compute 

Histogram button below coordinate axis. Click the Perfs/Actions button and check the 

options: Always show min/max markers and Update style to min/max and click here 

Recompute Histogram. 
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Figure 198. – Digital model of relief | histogram (relief_IDW) 

 

Analyzing the histogram, one can judge the prevailing height marks, maximum 

and minimum values. In this case, the horizontal axis displays the height values, and 

the vertical one shows the number (COUNT) of cells that fall into each of the classes. 

Step 11. Create an isoline layer based on the original raster terrain model. From 

the Raster menu, choose Extraction → Contour. In the Contours window that opens, 

specify in the “Input layer” – Digital Elevation Model as the source file. Set the Interval 

between contour lines to 10. Save the contour file to your folder under the name 

"Contour". Check the “Open output after running algorithm” and “Treat all raster 

values as valid”. Click Run and OK, fig. 199.  

 

 
 

Figure 199. – Contour dialog panel 
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Select “Single Labels” and “Value” – ELEV. Symbolize the "Contour" layer 

with a simple black line 0.25 mm wide. Label the isolines (Layer properties → Labels) 

with the values of the “ELEV” field in black color. Choose the font and size of the 

labels. Place (watercourses tab) labels along curves and over lines, fig. 200. The map 

with isolines is shown in fig. 201. 

Turn off the visibility of the "contour" layer. 

 

 
 

Figure 200. – Labeling of elevation isolines 

 

 
 

Figure 201. – Relief map with isolines 
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QGIS enables the analysis and processing of a digital elevation model (DEM) 

in various ways. The "Relief" analysis module can be used to calculate slope, exposure, 

ruggedness index. The slope for each raster cell indicates the maximum rate of change 

of value from that cell to its eight neighbors. 

Step 12. Calculate slopes within the study area. From the Raster menu, choose 

Analysis → Slope. Create a model with parameters as in fig. 202 (left). In the properties 

of the resulting draft model, on the Symbology tab, change the images from 

"Singleband gray" to "Singleband pseudocolor". Select the Blues color map. Click 

Classify, then Apply, fig 202. 

 

  
 

Figure 202. – Slope panel (left) and the map of slopes 

 

Step 13 Calculate the slope exposure model for the study area. From the Raster 

menu, choose Analysis → Aspect. In the Input layer field, select Digital elevation 

model, save the output layer under the name "aspect" in your working folder. Leave 

the rest of the settings as default. The exposure for each raster cell is defined as the 

direction of the steepest slope from that cell to its neighbors. It is measured in degrees 

from 0 to 360° clockwise from the north direction (0° – north, 90° – east, etc., fig. 203. 

On the Symbology tab for the Properties of the Aspect layer, change the images 

from "Singleband gray" to "Singleband pseudocolor". Select the Turbo color map. 

Click Classify, then Apply, you’ll get the exposition of slopes like in fig 203. 
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Figure 203. – Aspect dialogue (left) and the Slope exposure model (right) 

 

Step 14. You can use the external Viewshed Analysis module to calculate 

visibility areas. Open the Module Manager (Modules → Manage Modules). You need 

the Visibility Analysis module, check if it installed. Otherwise open the Not Installed 

tab, by entering part of the module name in the search bar, find the module of interest. 

Highlight Visibility Analysis in the list and click Install Plugin. Close the Module 

Manager. Once the extension is installed, the  Viewshed Analysis icon will appear 

in the plugins panel (Processing → Visibility Analysis → Analysis → Viewshed). 

Step 15 Create a new Observer point shapefile using the icon  located on the 

layer panel. When creating, specify the coordinate system: WGS 84 / UTM zone 35N. 

Start an editing session for the created layer. Use the  Add Object Anywhere 

tool to create an observer position. After that, end the editing session by agreeing to 

save the changes.  

Step 16. Calculation of visibility zones. From the Processing → Visibility 

Analysis → Analysis choose Viewshed.  

Calculation of visibility zones. Open Vievshed (Processing → Gdal → Raster 

miscellaneous→ Vievshed). In the dialog box that opens, specify relief_idw.tif in the 

empty "Input layer" window put cursor and click, it will convert into the hair cross (), 

move it into your map and overlay the created "observer" circle, click it and coordinates 

will be added to the "Observer location window". Set the "Maximum distance from 

observer to compute visibility" you can choose it arbitrary, for instance like shown in 

fig. 189. Enter the file name viewshed.tif with a path to its location. Check the "Open 

output file after running algorithm". Click Advanced → Algorithm settings and select 

"Do not filter (Better performance)", set the rest parameters similar to those shown in 

fig. 204. At the main panel click Run and Close after finishing the algorithm. 
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Figure 204. – The dialogue panel for viewshed 

 

It should be noted that the coordinate system of the terrain model and 

Observation points must be the same. The Search radius parameter sets the radius of 

the analyzed area around each observation point. The Maximum distance from 

observer to compute visibility and Target height metrics allow you to set heights for 

both the observer and the target. The default Observer height is 1.6, which is the eye 

level of a person of average height.  

As a result of the visibility analysis, the extension will create a raster whose cells 

will contain a code indicating whether they are visible from the observation point or 

not. For data selected for the example and chosen color scale (viewshed → Properties 

→ Singleband pseudocolor → say – RdBu with "Invert colors") the received viewshed 

looks like in fig. 205. Depending on the position of observation point you can get the 

different image. 
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Figure 205. – The viewshed image for our selection of parameters 

 

2.9. Laboratory work 9. Getting started in GRASS GIS via QGIS GUI 

 

Lab Objective: To learn the algorithm for creating a GRASS dataset in QGIS 

and performing raster GIS analysis operations while creating the least cost path. 

Initial data: 

● shapefile containing the boundary of the study area (boundary.shp); 

● shapefiles containing the river network of the study area (rivers.shp); 

● shapefile containing railways (railway.shp) and motor roads of the study area 

(roads.shp); 

● recreation center location shapefile (start_point.shp); 

 

Laboratory progress 

 

Extensions (plugins, modules) make up a significant and dynamically 

developing portion of QGIS functionality. GRASS plugin is an extension included in 

the QGIS core, one of the graphical interface options for the multifunctional GIS 

GRASS. Abbreviation GRASS (Geographic Resources Analysis Support System) is a 

well-known open source GIS with a wide array of useful GIS functions. It was first 

released in 1984. 

The main component of the Data is the Data Catalog which shows the GRASS GIS 

hierarchical structure consisting of Database , Location  and Mapset . 

 GRASS Database (directory with projects) 
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Running GRASS GIS for the first time, a folder named "grassdata" is automatically 

created. Depending on your operating system, you can find it in your $HOME 

directory (*nix) or My Documents (MS Windows). 

 Location (a project) 

A Location is defined by its coordinate reference system (CRS). In the case of the 

default Location, it is a geographic coordinate reference system WGS84 (EPSG: 

32635). If you have data in another CRS than WGS84, you should create a new 

Location corresponding to your system. 

 Mapset (a subproject) 

Each Location can have many Mapsets for managing different aspects of a project 

or project's subregions. When creating a new Location, GRASS GIS automatically 

creates a special Mapset called PERMANENT where the core data for the project 

can be stored. 

When working with GIS GRASS, all data used must be stored in a user-defined 

directory, which in GRASS terminology is called a geodatabase (DATABASE), fig. 

206. This is a regular directory that can be located anywhere in the directory tree on 

the user's computer or on the network. Within this directory, GRASS data is organized 

as projects, contained in subdirectories called LOCATIONs.  

 

 
 

Figure 206. – GRASS GIS Database structure as visible to the user 

 

The project area is defined by the coordinate system and spatial scope. Each area 

can contain multiple MAPSETs that are used to separate projects into different themes, 

sub-regions, or as separate sets for different working group members. In any area, at 

least one set must be defined, the name of which is PERMANENT. The latter is 

automatically generated by GRASS and, in several text files, contains basic 

information about the given area, such as coordinate system and projection parameters 

(PROJ_INFO and PROJ_UNITS). 

GRASS GIS Database. All data for GRASS GIS must be in GRASS GIS 

Database which is a directory (visible on the disk) containing subdirectories which are 

GRASS Locations. User can have one or more of Databases on the disk.  

GRASS GIS Databases can be safely copied or moved as any other directories. 

Don't be confused with (relational) databases which are used in GRASS GIS to hold 
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attribute data and might be part of the GRASS GIS Database. From user point of view, 

GRASS GIS Database with all its data in it is similar to, e.g. PostGIS, database, as it 

stores all information inside in a specific format and is accessible by specific tools. 

GRASS GIS Databases is in GRASS GIS often called GISDBASE or DATABASE. 

GRASS Locations. Location is a directory which contains GRASS Mapsets which 

are its subdirectories. All data in one Location have the same projection (coordinate 

system, datum). Each Location must contain Mapset called PERMANENT. Typically, 

a Location contains all data related to one project or a geographic area (geographic 

location or region). Alternatively, Location can simply contain all data in a given 

projection. 

GRASS Mapsets. Mapsets contains the actual data, mostly geospatial data, 

referred to as maps in GRASS GIS. Mapsets are a tool for organizing maps in a 

transparent way as well as a tool for isolating different tasks to prevent data loss. 

Mapsets are used to store maps related to one project, smaller project, specific task, 

issue or subregions. 

The role of the PERMANENT Mapset. When creating a new Location, GRASS 

GIS automatically creates a special Mapset called PERMANENT where the core data 

for the Location are stored. 

Since the maps in PERMANENT Mapset are visible from all the other Mapsets, 

it can be used to store the base maps (base cartography), data common to all projects 

or needed for different analyses done is separate Mapsets. 

 

I. Creating a GRASS GIS dataset 

Step 1. Open GRASS GIS 8.3.2 supplied together with QGIS 3.34. It permits 

using GRASS GIS functionality and/or visualize GRASS GIS vector and raster layers. 

When activating the module, two icons  and  (Open GRASS tools and Display 

Current Grass Region) will be added to toolbars. 

Step 2. Use the Add vector map layer tool to add the Mass_points, roads, 

Railway, rivers, Boundary, start_point shapefiles located in the source data folder to 

the QGIS project.  

Step 3. Specify the directory for the GRASS database by clicking the icon  

(Create new location in current GRASS database) and in the "Define new GRASS 

Location" panel which appears, fill in the "name" window, for instance "newLocation", 

"Location", or simply – "My Location" and click "Next" button, fig. 207. Another panel 

"Select Coordinate Reference System" pops up with a variety of possibilities to do this. 

Check the radiobutton "Select CRS from a list by EPSG or description" and click "Next". 

In one more panel, which appears "Define new GRASS Location" select "32635 WGS 84 

/ zone 35N" and click "Next", fig. 208. In the next panel "Select Datum Transformation” 

simply click OK, fig. 209.  
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Figure 207. – Creating a new location  
 

 
 

Figure 208. – Selecting a coordinate reference system  

 

 
 

Figure 209. – The select datum transformations window 
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In the final panel "Define new GRASS Location" (Summary) which opens with 

definitions for the project, click "Finish". The "Locations" directory will be added to 

your GRAS GIS project, fig. 210. The directory, names of layers and sets must 

contain Latin characters. 

 

 
 

Figure 210. – The Summary panel 

 

Step 4. GRASS data are stored in a tree directory structure. The GRASS 

Database is the top-level directory in this tree structure. The GRASS location is a 

collection of maps for a particular territory or a project. The GRASS region defines a 

workspace for raster modules. The default region is valid for one location. It is possible 

to set a different region in one mapset. The GRASS mapset is a collection of maps 

used by one user. A user can read maps of all mapsets in the location but he can open 

for writing only his mapset (owned by user). 

At this step, you need creating a mapset. To do this open Plugins → GRASS → 

New Mapset and click it, fig. 211. 

 

 
 

Figure 211. – Starting to create a new mapset 
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The GRASS Database panel appears, set within its window "Database 

directory", for instance C:\users\Dell\grassdata and click the "Next" button. It invokes 

another "GRASS Location" panel. Put the name, e.g. Test9 into the "Create new 

location" window and click "Next", fig. 212.  

 
 

Figure 212. – GRASS Database position (left) and the name of GRASS Location 

(right) 

 

The new panel appears to select the region of the world for which you’ll create 

maps. Select, for example here "Belarus" (Byelarus in the highlighted list) in the 

dropdown menu when clicking the corresponding arrow. Clicking the "Next" button 

invokes the "Mapset" panel, where you need entering a name of the mapset, for 

instance – new_mapset, click "Next" again, fig. 213. The final panel with the 

information on successful creating and set a current working mapset pops up, fig. 214. 

Click OK to close it. 

 

 
 

Figure 213. – Selecting the region and the name of a mapset 
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Figure 214. – Final panel creating of a mapset process 

 

Now both icons  (Open GRASS Tools) and  (Display Current GRASS 

Region) become accessible. Clicking GRASS Tools ( ) you can see accessible the 

list of "GRASS MODULES", fig. 215. 
 

 
 

Figure 215. – List of GRASS modules 
 

Import the vector layers loaded into the QGIS project into the created GRASS 

GIS database. On the GRASS toolbar, click the  (Open GRASS Tools) icon. The 

GRASS tool window will appear. On the "GRASS MODULES" tab open File 

Management → Import into GRASS → Import Vector into GRASS → v.in.ogr.qgis 

Import loaded vector (fig. 216). 
 

 
 

Figure 216. – GRASS GIS - loading a vector file 
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The tab of the activated tool Module is added to the GRASS Tools window: 

v.in.ogr.qgis. Load the vector layers Boundary.shp from your source folder (Layer – 

Add layer – Add vector layer) into QGIS. Symbolize loaded layers on your choice. An 

example is shown in fig. 217. 
 

 
 

Figure 217. – Source map with loaded vector layers 
 

In GRASS Tools window (see fig. 201) click "v.in.ogr.qgis" from the Loaded 

layer drop-down list, select "Boundary". Name the output layer "boundary1". Click 

Run (fig. 218). 
 

 
 

Figure 218. – Selecting the layer in GRASS instruments 
 

When Successfully finished appears, click the View output button, then click 

"Close". The feature layer "boundary1" imported into GRASS will be added to the 

QGIS map window. Similarly, repeat these steps click "v.in.ogr.qgis" at the "Modules" 

panel, from the Loaded layer drop-down list, select and download sequentially the 
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"Mass_points", "roads", "railway", "rivers", and "start_point" layers to the 

"study_area" set and to the QGIS map window, naming "mass_points1", "roads1", 

"railway1", and "rivers1", "start_point1" respectively.  

If there will be some unsuccessful attempt (Finished with error) to create one of 

"*1" layers (for instance – railway1) you may click "Close", then "Reset" in the 

"Region" subpanel and continue working. 

Step 5 Remove or disable the "Mass_points", "roads", "railway", "rivers", and 

"start_point" layers from the QGIS project. Symbolize the "rivers1" layer with a 

"Single symbol" (  icon), Layer type – "Simple line", Line style – "Solid line", Line 

color – blue, "Widths" – 0.5 mm. For the "roads1" layer, change the color of the line 

to graphite, set the Width to 0.8 mm. 

Draw the railroad layer with a "Single symbol" ( ). On the Symbology tab of 

the Layer Properties dialog box, click on the first sign level (Line) and in the Signs 

group that appears, select Dash black. Change the color of the lines that make up the 

symbol to black and white. 

Step 6. Click the icon  Display Current GRASS Region in the GRASS toolbar. 

The border of the current GRASS region will be displayed as a red line in the QGIS 

map window. Region display GRASS can be disabled/enabled using the icon . 

Region definition (setting spatial characteristics) in GRASS is important for working 

with raster data. All newly created raster will have the spatial coverage and resolution 

of the current GRASS region (regardless of their original coverage and resolution). 

Let's reduce the border of the current GRASS region to the border of the boundary1 

layer. To do this, in the floating GRASS Tools panel, go to the Region tab. Click the 

Select the extent by dragging on canvas button. Place the cursor on the QGIS map area 

and, by pressing the left mouse button, select the rectangle corresponding to the 

"boundary1" layer. Click the Apply button in the Region tab of the GRASS Tools panel, 

fig. 219. 
 

 
 

Figure 219. – Selected area 
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Step 7. The point layer "mass_points1" is a set of elevations. Build a digital 

elevation model based on this layer. Select GRASS Modules → Raster → Surface 

Processing → Surface Interpolation in the Open GRASS Tools panel. In the list of 

interpolation tools, select v.surf.rst – Regularized spline with tension raster 

interpolation based on vector points to open the tool options window, fig. 220.  
 

 
 

Figure 220. – Selecting the surface interpolation dialogue 
 

Set the source vector layer to "mass_points1", Attribute fields to H in the tool 

tab. Leave the other options at their defaults. In the Name for Output surface elevation 

raster map window, type relief and click Run, fig. 221. 
 

 
 

Figure 2.221 – GRASS dialogue panel 
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The process will take some time. When the "Output window" displays 

Successful, click Open Output and then Close. Tre results of an interpolation looks like 

shown in fig. 222. 

 

 
 

Figure 222 – Relief of the area 

 

II. Finding a path with the minimum cost 

Step 8. GIS analysis of distances. The main task of the GIS analysis is to obtain 

the optimal path with the lowest cost from the road to the recreation center, located 

within the study area, taking into account a number of terrain features (relief slope and 

land use type). The digital elevation model of the study area was obtained at the 

previous step. The reclassified land use type raster (landuse.tif) is located in the source 

data folder. 

Computing the optimal path involves several steps: 

1. Slope calculation using r.slope. 

2. Reclassify the slope raster using rules. 

3. Combining the reclassified raster. 

4. Calculate the total cost of the move raster using r.cost. 

6. Finding the optimal way to move. 

Calculate slopes within the study area. In the list of Open GRASS Tools, select 

(Raster → Spatial Analysis → Terrain Analysis → r.slope). Select in the tool tab the 

“relief” layer created in the previous step as the input hypsometric surface. Name the 

output surface "slope" (fig. 223). Click Run and after finishing the algorithm, click 

View output, the image will be overlaid to the raster map, fig. 224. 

 



141  

 
 

Figure 223. – Working with GRASS – terrain analysis - slope 

 

 
 

Figure 224. – Terrain analysis – slope image 

 

Step 9: Reclassify the slope raster. To perform the operation, you need to create 

a text file with reclassification rules. We use a scale from 1 to 5 by assigning a value 

to the five cells with the largest in within the study area a slope (3.6–4.5º), and one – 

the smaller (< 0.9º). Open Notepad (All Programs → Accessories → Notebook). Type 

the following few lines in the program window (no spaces in between symbols): 

0: 0.9 : 1 : 1  

0.9 : 1.8 : 2 : 2  

1.8 : 2.7 :3 :3  

2.7 : 3.6 : 4 : 4  

3.6 : 4.5 : 5 : 5  
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The first two numbers on the line, separated by a colon (0:0.9), indicate the range 

of values in the input raster. The last two (1:1) here are the new value of the specified 

range in the output raster. Save the reclassification rules to a text file slope_reclass.txt. 

In the list of Open GRASS Tools, select r.recode – Recode categorical raster 

using reclassification rules (Open GRASS Tools → Raster → Change category and 

label values). Select slope as the input raster in the tool tab. Specify slope_reclass.txt 

in the File containing recoding rules field. Save the output raster in your folder as 

"slope_reclass" (Figure 225). When the reclassification is complete, click Open Output 

and then Close.  
 

 
 

Figure 225. – Slope – reclassification steps 
 

The reclassified slope image is shown in fig. 226. 

 

 
 

Figure 226. – Reclassified slope image overlaid the relief 
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Step 10. Using the  Add Raster Layer tool, add the 1_landuse raster to the 

QGIS project located in the source data folder. Specify the coordinate system for the 

layer: WGS 84 / UTM zone 35N. Open File Management → Import into GRASS → 

Import Raster into GRASS → Import Rasterinto GRASS from QGIS view → 

r.in.gdal.qgis – Import loaded raster in the GRASS Modules tab of the Open GRASS 

Tools panel. Select "landuse" as the loaded layer in the r.in.gdal.qgis tab. Enter 

landuse_reclass in the Name of output raster map field, and click Run. After finishing 

the algorithm click "View output" and the layer will be added to your project, fig. 227. 

 

 
 

Figure 227. – Landuse reclassified 

 

Step 11. Combine the reclassified slope_reclass and landuse_reclass datasets. 

Go to Raster → Spatial analysis → Map algebra in the Modules tab of the Open 

GRASS Tools panel,. Activate the tool r.mapcalc – Graphing raster map calculator. 

In the dialog box, using the Add Map,  Add operator or function, and  Add 

connection tools, create a diagram as shown in fig. 228. When a tool is selected, the 

corresponding elements (layers, operators) become available in the list below. Type 

slope_landuse in the Output field, and click Run. After the operation is completed, 

click Open output and close the module window. 

Step 12 Create a cost raster. To do this, on the Modules tab, open GRASS 

Modules → Raster → Spatial Analysis → Morphometric Analysis → r.cost.vect 

Create a raster layer of the cumulative cost of moving between points based on a raster 

of cost values and a vector of starting points. In the tool tab, select slope_landuse as 

the input raster, start_point – as the start point feature layer, and cost – as the output 

raster, fig. 229. Click the More options button and in the Cost assigned to null cells 

line, specify 1. Click Run. 
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 Figure 228. – Hillshade algorithm 

  

 

 

Figure 229. – Adding raster layers 

 

Step 13 Calculate using GIS the shortest route from the railroad to the chosen 

place of your rest. Activate the module r.drain Generate flow from terrain model 

(GRASS Modules → Raster → Spatial Analysis → Morphometric Analysis) in the list 

of GRASS tools. In the module tab in the drop-down list, select the input raster - cost, 

type the name of the output raster (costpath), set the coordinates of the starting point 

of the path, fig. 230. Click Run, then Open Output and close the module window. 
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Figure 230. – Analysis of costs panel 

 

Step 14. Open GRASS Modules → File Management → Data Type Conversion 

→ Raster to Vector GRASS → r.to.vect.line. Convert raster layer to vector lines in the 

Modules tab of the GRASS Tools panel. In the tool tab, select the source raster – 

costpath. Name the output layer "least_cost_path". Click Run. Add the resulting layer 

to the map window. Close the module. 

Symbolize the "least_cost_path" layer with a regular symbol, choose the symbol 

Construction road. 

For the "cost" layer, set the rendering style to Single Channel Pseudo Color. 

Select the YlOrRed color map In the Color field. The mode is continuous. Click the 

Classify button, then OK. 

Turn off the visibility of the raster layers "relief", "slope", "slope_reclass", 

"landuse_reclass", "slope_landuse" (fig. 231). 

 

 
 

Figure 231 – Final cost path route 
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3. KNOWLEDGE CONTROL SECTION 

 

3.1. Questions for the discipline exam  

(for parts 1 and 2) 

1. The main software products discussed in the course "GIS in Mineral Resource 

Management". 

2. Types of computer hardware and trends in their development. The processor, 

input and output devices, operational and long-term memory, printers, plotters in 

computers. 

3. Problems solved with the use of computer processing tools. Give some 

examples. 

4. Sources and types of data used for further processing in GIS: Earth remote 

sensing data, earthquake catalogs, geological maps, data on gravity and magnetic 

fields, well logs, relief, etc. 

5. Using GMT for processing geological and geophysical data and constructing 

graphs, diagrams, and maps. 

6. Main options in GMT software package commands: -R, -J, -B, -O, -K, -G, -g, 

-I, REM. How to select coordinate systems and projections. 

7. How to convert the Post Script output format of graphics in the GMT 

environment to other formats (jpg, tiff, png, pdf). Show an example of converting to 

other formats using one of labs completed by you as an example. 

8. How to identify the boundaries of lithospheric plates, active faults in the 

oceans using computer graphics? Consider an example from your tests.  

9. Which seaquakes are dangerous in terms of tsunamis? Give an example of the 

computer test for the Sea of Japan region. 

10. Classic (traditional) and modern (modern) methods of writing scripts in 

GMT 

11. The computer software package “QGIS”, its modular structure and interface 

features. Types of tests fulfilled by you using the QGIS. 

12. Vector and raster data, their difference. Layers in QGIS. Raster model for 

representing spatial data in GIS. Advantages and disadvantages of the raster model.  

13. Purpose of bases for storing and processing geological data. 

14. Definition of GIS. Basic components and functionality of GIS. 
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15. GIS classifications. Composition capabilities of GIS software products. 

16. Data sources necessary for constructing geological maps, profiles, sections. 

17. Data sources for GIS: Satellite data, geodetic technologies, databases. 

18. Capabilities of the Surfer software and its use. 

19. Using the Geostatistics software modules. 

20. Purpose and capabilities of the QGIS software package. 

21. Types of geological problems solved using the QGIS software package. 

22. Construction of geological sections and profiles using GIS software. 

23. General characteristics of the complex of GIS software, products ArcGIS. 

24. Overview of additional ArcGIS GIS capabilities. 

25. Brief overview of geographic coordinate systems used in mapping. 

26. Raster model for representing spatial data in GIS. Advantages and 

disadvantages of the raster model. The most common raster formats for representing 

spatial data in GIS. 

27. Overview of the vector format and raster data - geodatabase. 

28. Methods for classifying quantitative geodata in GIS. Georeferencing raster 

images. 

29. Spatial statistics in GIS. 

30. Processing of geological data in GIS. 
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3.2. Abstract topics 

 

The independent work (abstract) includes 8 examples, they are tests (laboratory 

workss 1 – 9)..  

1. Laboratory work 1: QGIS basic techniques.  

2. Laboratory work 2: Geographical linking of raster in QGIS.  

3. Laboratory work 3: Creating point layers from text data in QGIS. Heat maps.  

4. Laboratory work 4: Creating a tourist map in QGIS.  

5. Laboratory work 5: Receiving basic spatial characteristics of objects in 

QGIS.  

6. Laboratory work 6: Joining tables in QGIS.  

7. Laboratory work 7: Search the shortest route with road graph for QGIS.  

8. Laboratory work 8: Construction and analysis of a digital relief model.  

9. Laboratory work 9: Getting started in GRASS GIS via QGIS GUI. 
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3.3. Organization of independent work 

 

The independent work is carried out on the basis of the Regulations on 

independent works of students (undergraduates, students), approved by the Minister of 

Education of the Republic of Belarus on April 6, 2015. 

In the discipline studied, it is planned: 

- Performing creative and research tasks; 

- Work with published sources, including scientific articles; 

- Study of topics and problems that are not covered in lectures; 

- Scientific reports; 

- Writing thematic reports and essays on problematic topics. 

 

List of recommended diagnostic tools: 

- Oral surveys – 25%; 

- Interviews – 25%; 

- Report on practical work – 25%; - laboratory tests – 25%. 

 

Methodology for generating the final assessment. The final assessment is formed 

based on three documents: 

1. Rules for certification (Resolution No. 53 of May 29, 2012);  

2. Regulations on the BSU rating system; 

3. Student assessment criteria (passed). 

4. The final grade is formed from the rating assessment of the final control of 

current progress (40%) and the result of the answer at the test (60%). 

List of recommended diagnostic tools and methodology for forming the final 

assessment. The form of the current certification in the discipline “GIS in mineral 

resource management” is provided by the curriculum for credit. The final assessment 

is based on three documents:  

1. Rules for conducting certification of students, cadets, listeners when mastering 

the content of educational programs of higher education (Resolution of the Ministry of 

Education of the Republic of Belarus dated May 29, 2012 No. 53).  
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2. Regulations on the rating system for assessing students’ knowledge in an 

academic discipline at BSU (Order of the Rector of BSU No. 189-OD dated March 31, 

2020).  

3. Criteria for assessing the results of educational activities of students in higher 

education institutions on a ten-point scale (Letter of the Ministry of Education of the 

Republic of Belarus dated May 28, 2013 No. 09-10/53-PO).  

The assessment of the degree of mastery of theoretical material is checked through 

regular testing. To assess the degree of completion of laboratory work, undergraduates 

prepare a written report, which is checked by the teacher.  

When forming the final grade, a rating assessment of the student’s knowledge 

used, which makes it possible to trace and evaluate the dynamics of the process of 

achieving learning goals. The rating assessment involves the use of weighting 

coefficients for the current control of knowledge and the current certification of 

master's students in the discipline.  

Approximate weighting coefficients that determine the contribution of forms 

(events) of current knowledge control to the assessment of current academic 

performance: electronic tests (arithmetic average of grades for all electronic tests) – 

40%; – written reports on laboratory work (the arithmetic mean of marks for written 

reports on all laboratory works) – 60%. The final grade for the discipline is calculated 

based on the assessment of current performance and the answer to the test, taking into 

account their weighting 10 coefficients. The weight of the assessment for current 

performance is 40%, the assessment for the test is 60%. 
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4. AUXILIARY SECTION 

Full-time education for students 

4.1. Educational and methodological map for the academic discipline 

(for parts 1 and 2) 

 

  

  
Title of section, topics, activities 

Number of classroom hours  

In
d
ep

en
d

en
t 

w
o

rk
 Knowledge control form  

 

   

 

1  2  3  4  5  6  7  8  9   
1  Mineral resources. Introduction               

1.1  General introduction to the subject 1           Oral survey, test  

1.2  Mining technology and excavation of  

minerals 
1          Oral survey, test  

2  Main kinds of software packages             

2.1  ArcGIS / QGIS. General Introduction and functionality. 

Geographic space modeling. Representation models. 
2    2  4    Oral survey, test  

2.2  GMT, Oasis Montaj. General Introduction and 

functionality 
2     2 8   Oral survey, test   

2.3  Surfer. General Introduction and functionality 1     2   Oral survey  

3  Laboratory practice and tests 2              

3.1 Laboratory models using QGIS software packages.     2 4 Report on the laboratory work  
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3.2 Laboratory models using GMT software package.     2 4 Report on the laboratory work  
3.3 Laboratory models and Oasis Montaj Viewer software 

package 

     2 Report on the laboratory work  

3.4 Laboratory tests using Surfer software package.     2 2 Report on the laboratory work  
3.5 Laboratory tests using Strater software package     2  Testing  
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4.2. Recommended reading  

(for parts 1 and 2) 

Main  

1. Rocks and the Rock Cycle. 

 URL: 

https://serc.carleton.edu/integrate/teaching_materials/mineral_resources/student_m

aterials/unit1reading.html  – Access date: 09.09.2024. 

2. Types of minerals. URL: https://www.brainkart.com/article/Mineral-

Resources_41102– Access date: 09.09.2024. 

3. A map of England, showing the mining sites for some mineral resources. 

URL: https://www.studysmarter.co.uk/explanations/environmental-

science/physical-environment/mineral-resources– Access date: 09.09.2024. 

4. Gold-bearing quartz vein from California. URL: 

https://bio.libretexts.org/Courses/University_of_Pittsburgh/Environmental_Scienc

e_(Whittinghill)/06%3A_Geology/6.05%3A_Geologic_Resources/6.5.01%3A_Mi

neral_Resources– Access date: 09.09.2024. 

5. Gold crystal. URL: https://geo.web.ru/druza/m-Au_0.htm– Access date: 

09.09.2024. 

6. Lithium. URL: 

https://cyclowiki.org/wiki/%D0%9B%D0%B8%D1%82%D0%B8%D0%B9 

– Access date: 09.09.2024. 

7. The rust color of hematite (left) and the rust-yellow color of limonite (a 

variety of goethite, right) have long been used for pigments. URL:  

https://serc.carleton.edu/integrate/teaching_materials/mineral_resources/student_m

aterials/unit1reading.html. – Access date: 09.09.2024. 

8. Global distribution of peatlands. URL: 

https://www.grida.no/resources/12546– Access date: 09.09.2024. 

9. How do we extract minerals. URL:  https://www.usgs.gov/faqs/how-do-

we-extract-minerals– Access date: 09.09.2024. 

10. Zui, V.I. Introduction to GMT. Minsk: BSU. 2023. 51 p. 

https://elib.bsu.by/handle/123456789/298166 - Access date: 09.09.2024. 

11. Zhukovskaya, N.V. Introduction to GIS on the basis QGIS [Введение в 

ГИС на основе QGIS]. Minsk: BSU. 2018. 132 p. (in Russ.). URL: 

https://elib.bsu.by/handle/123456789/196241?locale=en 

12. Xavier de Lamo. Introduction to QGIS. URL: 

https://www.google.com/search?q=Xavier+de+Lamo.+Introduction+to+QGIS&rlz

=1C1GCEA_enBY1003BY1003&oq=Xavier+de+Lamo.+Introduction+to+QGIS

&gs_lcrp=EgZjaHJvbWUyBggAEEUYOTIKCAEQABiABBiiBDIKCAIQABiA

https://serc.carleton.edu/integrate/teaching_materials/mineral_resources/student_materials/unit1reading.html
https://serc.carleton.edu/integrate/teaching_materials/mineral_resources/student_materials/unit1reading.html
https://www.brainkart.com/article/Mineral-Resources_41102
https://www.brainkart.com/article/Mineral-Resources_41102
https://www.studysmarter.co.uk/explanations/environmental-science/physical-environment/mineral-resources
https://www.studysmarter.co.uk/explanations/environmental-science/physical-environment/mineral-resources
https://bio.libretexts.org/Courses/University_of_Pittsburgh/Environmental_Science_(Whittinghill)/06%3A_Geology/6.05%3A_Geologic_Resources/6.5.01%3A_Mineral_Resources
https://bio.libretexts.org/Courses/University_of_Pittsburgh/Environmental_Science_(Whittinghill)/06%3A_Geology/6.05%3A_Geologic_Resources/6.5.01%3A_Mineral_Resources
https://bio.libretexts.org/Courses/University_of_Pittsburgh/Environmental_Science_(Whittinghill)/06%3A_Geology/6.05%3A_Geologic_Resources/6.5.01%3A_Mineral_Resources
https://geo.web.ru/druza/m-Au_0.htm
https://cyclowiki.org/wiki/%D0%9B%D0%B8%D1%82%D0%B8%D0%B9
https://serc.carleton.edu/integrate/teaching_materials/mineral_resources/student_materials/unit1reading.html
https://serc.carleton.edu/integrate/teaching_materials/mineral_resources/student_materials/unit1reading.html
https://www.grida.no/resources/12546
https://www.usgs.gov/faqs/how-do-we-extract-minerals
https://www.usgs.gov/faqs/how-do-we-extract-minerals
https://elib.bsu.by/handle/123456789/298166
https://www.google.com/search?q=Xavier+de+Lamo.+Introduction+to+QGIS&rlz=1C1GCEA_enBY1003BY1003&oq=Xavier+de+Lamo.+Introduction+to+QGIS&gs_lcrp=EgZjaHJvbWUyBggAEEUYOTIKCAEQABiABBiiBDIKCAIQABiABBiiBNIBCTI5MDZqMGoxNagCALACAA&sourceid=chrome&ie=UTF-8
https://www.google.com/search?q=Xavier+de+Lamo.+Introduction+to+QGIS&rlz=1C1GCEA_enBY1003BY1003&oq=Xavier+de+Lamo.+Introduction+to+QGIS&gs_lcrp=EgZjaHJvbWUyBggAEEUYOTIKCAEQABiABBiiBDIKCAIQABiABBiiBNIBCTI5MDZqMGoxNagCALACAA&sourceid=chrome&ie=UTF-8
https://www.google.com/search?q=Xavier+de+Lamo.+Introduction+to+QGIS&rlz=1C1GCEA_enBY1003BY1003&oq=Xavier+de+Lamo.+Introduction+to+QGIS&gs_lcrp=EgZjaHJvbWUyBggAEEUYOTIKCAEQABiABBiiBDIKCAIQABiABBiiBNIBCTI5MDZqMGoxNagCALACAA&sourceid=chrome&ie=UTF-8
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BBiiBNIBCTI5MDZqMGoxNagCALACAA&sourceid=chrome&ie=UTF-8 – 
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